Jump to content

bendsch

Membres
  • Content Count

    13
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bendsch

  • Rank
    Qnapeur fidèle

Profile Information

  • Matériel
    Futur Qnapeur

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. bendsch

    Apache & PHP 7.4.x

    does this package contain php-fpm or will it ever contain it?
  2. bendsch

    PHP-FPM

    does this play along with apache_7.4 qpkg? (or in other words: is apache_7.4 qpkg making use of internal php?). cheers bendsch
  3. bendsch

    NextCloud (Apache74)

    trying to make this work together wir QMariaDB (since internal MariaDB is still on 5.xx). nextcloud can be started but is not reachable, so my guess is, that apache74 tries to connect to the internal MariaDB socket. Any hints where i can point Apache74 and/or Nextcloud74 to /tmp/QMariadDB2.sock ?
  4. bendsch

    NextCloud (Apache74)

    Qoolbox replied to my question and it seems like he resolved the issue. so apparently with the newest version posted above install should be running. i though it would still be interesting for users upgrading vom Nextcloud/Qapache to see Qoolboxes answer: added to the config file on last line : /share/CACHEDEV1_DATA/.qpkg/NextCloud74/nextcloud/config/config.php 'hashing_default_password' => true, config file look like this one after a second setup (tested with sqlite and apache74, but this trick should work for all DB and Apache73) <?php $CONFIG = array ( 'instanceid' => 'ocg61wiq87m3', 'passwordsalt' => 'ydniAQlWFcDG9MMAWzMlK8XkvgLZro', 'secret' => 'O2DHiLvehj3VCsRPCak+sHUzSUXcJOPnJ9+knoHrN8qYJ5O5', 'trusted_domains' => array ( 0 => '192.168.0.59:35180', ), 'datadirectory' => '/share/CACHEDEV1_DATA/.qpkg/NextCloud74/nextcloud/data', 'dbtype' => 'sqlite3', 'version' => '18.0.4.2', 'overwrite.cli.url' => 'http://192.168.0.59:35180', 'hashing_default_password' => true, ); other solution found by user on www.forum-nas.fr seems that there is bug with PASSWORD_ARGON2I algorithm to generate password. Solution: comment lines 208, 209, 210 in nextcloud/lib/private/Security/Hasher.php such that they look like: //if (\defined('PASSWORD_ARGON2I')) { // $default = PASSWORD_ARGON2I; //} I managed to upgrade from my Nextcloud/Qapache to NextCloud74/Apache74 by just copying ".qpkg/NextCloud/nextcloud" to ".qpkg/NextCloud74/nextcloud" (overwrite it) and adding the line " 'hashing_default_password' => true," to ".qpkg/NextcCoud74/nextcloud/conf/config.php" (like described by Qoolbox). Then i copied my server.crt and server.key from ".qpkg/NextCloud" to ".qpkg/NextCloud74". Last thing i did is changing the https-port in ".qpkg/NextCloud74/NextCloud74/NextCloud74.sh" back to "45083 in order to work with my old config, bookmarks and domain . Then restarted Apache74 and Nextcloud74 and everything worked as expected. Happy upgrading and many thanx to the developer Bendsch
  5. bendsch

    NextCloud (Apache74)

    how to contact him?
  6. bendsch

    NextCloud (Apache74)

    what do you mean? i did not make any progress and don't know how to resolve it, i think only the developer can help, but unfortunately he does not seem to read the forums. any idea how to get in touch with him=
  7. bendsch

    NextCloud (Apache74)

    not sure if this addresses our issue ... it is probably something the developer of the package should solve, since we all paid for it.
  8. bendsch

    NextCloud (Apache74)

    ok, will look into this a bit later today. please let me know if it ist working.
  9. bendsch

    NextCloud (Apache74)

    yes, it' s exactly the same for me. i also had a working qapache/nextcloud installation before trying to upgrade to apache 7.4 (in hope of improvements in speed). i am on a ts-251+ was it working for you after that? to be honest, i am a bit lost here. since the command-line-install fails only with the message "illegal instruction" (after creating the database and running for a couple of minutes), there is not much information for troubleshooting.
  10. bendsch

    NextCloud (Apache74)

    hello there it's not a white screen, actually the next site (after filling in the configuration-data on the install-landing-page and clicking "install") does not load at all: grey screen with message "no response from server" in my browser. after trying to install by command line, which also failed, i am convinced that the issue has to do with apache 7.4's php - it's not just about site-loading and it looks like it is not a permission/certificate error either (tried without https: same result) .
  11. bendsch

    Apache & PHP 7.4.x

    just bought apache 74 and to install nextcloud(apache74)-package. after several hours of trying, no luck with installation. #1 tried to install with webinterface: install proceeds to blank page ("no response from server"), tried sqlite and mysql : same result #2 tried to install by commandline: /share/CACHEDEV1_DATA/.qpkg/Apache74/bin/php ./nextcloud/occ maintenance:install --database "mysql" --database-name "Nextcloud74" --database-user "Nextcloud74" --database-pass "pass" --admin-user "User" --admin-pass "pass" -vvv error message: "Illegal instruction" i can see that some tables have been created in phpmyadmin, so connection to mysql should not be the problem. #3 tried to download nextcloud.zip into the root directory, unpacked it in ./nextcloud and tried #1 and #2 again: same result so the nextcloud package should not be the problem i suspect that apache74 php is just not working with nextcloud as suggested (which actually feels a bit odd, after paying for a package that is based on freeware). any help please?
  12. bendsch

    NextCloud (Apache74)

    just bought apache 74 and to install this package. after several hours of trying, no luck with installation. #1 tried to install with webinterface: install proceeds to blank page ("no response from server"), tried sqlite and mysql : same result #2 tried to install by commandline: /share/CACHEDEV1_DATA/.qpkg/Apache74/bin/php ./nextcloud/occ maintenance:install --database "mysql" --database-name "Nextcloud74" --database-user "Nextcloud74" --database-pass "pass" --admin-user "User" --admin-pass "pass" -vvv error message: "Illegal instruction" i can see that some tables have been created in phpmyadmin, so connection to mysql should not be the problem. #3 tried to download nextcloud.zip into the root directory, unpacked it in ./nextcloud and tried #1 and #2 again: same result so the nextcloud package should not be the problem i suspect that apache74 php is just not working with nextcloud as suggested (which actually feels a bit odd, after paying for a package that is based on freeware). any help please?
  13. bendsch

    Lidarr

    Update function does not work with this qpkg (0.30.430). it fails with following message: [v0.3.0.430] NzbDrone.Core.Update.UpdateFailedException: Your Lidarr configuration '/share/CACHEDEV1_DATA/.qpkg/Lidarr/lidarr/.config/Lidarr' is being stored in application folder '/share/CACHEDEV1_DATA/.qpkg/Lidarr/lidarr' which will cause data lost during the upgrade. Please remove any symlinks or redirects before trying again. at NzbDrone.Core.Update.InstallUpdateService.EnsureAppDataSafety () [0x0006f] in <4bf81ae1ec7844d9b52ed2972521af00>:0 at NzbDrone.Core.Update.InstallUpdateService.InstallUpdate (NzbDrone.Core.Update.UpdatePackage updatePackage) [0x00000] in <4bf81ae1ec7844d9b52ed2972521af00>:0 at NzbDrone.Core.Update.InstallUpdateService.Execute (NzbDrone.Core.Update.Commands.ApplicationUpdateCommand message) [0x0006e] in <4bf81ae1ec7844d9b52ed2972521af00>:0 18-7-26 15:29:53.3|Error|CommandExecutor|Error occurred while executing task ApplicationUpdate [v0.3.0.430] NzbDrone.Core.Messaging.Commands.CommandFailedException: Failed ---> NzbDrone.Core.Update.UpdateFailedException: Your Lidarr configuration '/share/CACHEDEV1_DATA/.qpkg/Lidarr/lidarr/.config/Lidarr' is being stored in application folder '/share/CACHEDEV1_DATA/.qpkg/Lidarr/lidarr' which will cause data lost during the upgrade. Please remove any symlinks or redirects before trying again. at NzbDrone.Core.Update.InstallUpdateService.EnsureAppDataSafety () [0x0006f] in <4bf81ae1ec7844d9b52ed2972521af00>:0 at NzbDrone.Core.Update.InstallUpdateService.InstallUpdate (NzbDrone.Core.Update.UpdatePackage updatePackage) [0x00000] in <4bf81ae1ec7844d9b52ed2972521af00>:0 at NzbDrone.Core.Update.InstallUpdateService.Execute (NzbDrone.Core.Update.Commands.ApplicationUpdateCommand message) [0x0006e] in <4bf81ae1ec7844d9b52ed2972521af00>:0 --- End of inner exception stack trace --- at NzbDrone.Core.Update.InstallUpdateService.Execute (NzbDrone.Core.Update.Commands.ApplicationUpdateCommand message) [0x000ee] in <4bf81ae1ec7844d9b52ed2972521af00>:0 at NzbDrone.Core.Messaging.Commands.CommandExecutor.ExecuteCommand[TCommand] (TCommand command, NzbDrone.Core.Messaging.Commands.CommandModel commandModel) [0x000d0] in <4bf81ae1ec7844d9b52ed2972521af00>:0 at (wrapper dynamic-method) System.Object.CallSite.Target(System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,NzbDrone.Core.Messaging.Commands.CommandExecutor,object,NzbDrone.Core.Messaging.Commands.CommandModel) at System.Dynamic.UpdateDelegates.UpdateAndExecuteVoid3[T0,T1,T2] (System.Runtime.CompilerServices.CallSite site, T0 arg0, T1 arg1, T2 arg2) [0x00035] in <7ffe722dd31b49be81844ccf72ae37cb>:0 at (wrapper dynamic-method) System.Object.CallSite.Target(System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,NzbDrone.Core.Messaging.Commands.CommandExecutor,object,NzbDrone.Core.Messaging.Commands.CommandModel) at NzbDrone.Core.Messaging.Commands.CommandExecutor.ExecuteCommands () [0x0008c] in <4bf81ae1ec7844d9b52ed2972521af00>:0
×