Jump to content

Recommended Posts


Description: Password management solution for individuals, teams, and business organizations. Solve your password management problems The easiest and safest way for individuals, teams, and business organizations to store, share, and sync sensitive data YOUR ONLINE SAFETY IS AT RISK Password theft is a serious problem. The websites and apps that you use are under attack every day. Security breaches occur and your passwords are stolen. When you reuse the same passwords everywhere hackers can easily access your email, bank, and other important accounts. HOW DO YOU STAY SAFE? Security experts recommend that you use a different, randomly generated password for every online account that you create. But how are you supposed to remember and keep up with that many passwords? Bitwarden helps you create and manage secure passwords so that you can get back to enjoying your life online. [ QPKG Integration] - Based on BitWarden_rs use port 8000 disable all ADBlock on webrowser (or create rules) prefix install : /opt/Bitwarden <img src="https://community-home-assistant-assets.s3.dualstack.us-west-2.amazonaws.com/optimized/3X/1/5/157bd7877570c30ba653910b3276d74e95fa3c3d_2_690x431.png" class="img-responsive" alt="157bd7877570c30ba653910b3276d74e95fa3c3d_2_690x431.png"><b>BUY IT NOW</b> Your gratitude and finance will help me to continue integration of this QPKG and maintain up to date versions. <b>Greetings to</b> dani-garcia : https://github.com/dani-garcia/bitwarden_rs/
Créateur: QoolBox

Share this post


Link to post
Share on other sites

Does not work on my QNAP TS-251: when I tried to enter my account, I got error: Cannot read property 'importKey' of null

Version x86-64. Account is configured with 2 factor authentication (maybe this is a par of use case)

This occurs in chrome only.

When I tried to configure Windows client to use local server-I got error "Failed to fetch" on login

The only way I succeeded to access server is with Microsoft Edge

This version is completely unusable

Maintainer, please fix

 

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.9.1

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.9.1

Share this post


Link to post
Share on other sites

Latest version 1.9.1 is much, much better than 1.9.0.   Now I can connect both with Android application and with Windows client, even Chrome extension connects  (but error: Cannot read property 'importKey' of null from Chrome browser is still here). Thanks to maintainer for the fix. Now the only thing I have to understand is how to configure https access so that I will be able to enter from Google Chrome. 

Maybe somebody can write some small instruction, how to configure https access for this QNAP package? As first step, I installed LeGo qpkg - Let's Encrypt console client, and of course I have basic knowledge about SSH access, shell commands and port forwarding on home router.  But I don't know, how to configure this package to use certificate (this is what is written in manual about Docker image) e.t.c. and I'm not Linux guru.

Tiny step by step instruction will be appreciated

Best regards  

 

  • Like 1

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.9.1

Share this post


Link to post
Share on other sites

Hi,

I've just generated my certificates with lego (interface to Let'sEncrypt)

Please explain, how to do this with qpkg package:

 

To enable HTTPS, you need to configure the ROCKET_TLS.

The values to the option must follow the format:

ROCKET_TLS={certs="/path/to/certs.pem",key="/path/to/key.pem"}

Where:

  • certs: a path to a certificate chain in PEM format
  • key: a path to a private key file in PEM format for the certificate in certs
docker run -d --name bitwarden \
  -e ROCKET_TLS='{certs="/ssl/certs.pem",key="/ssl/key.pem"}' \
  -v /ssl/keys/:/ssl/ \
  -v /bw-data/:/data/ \
  -p 443:80 \
  bitwardenrs/server:latest

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.10.0

Share this post


Link to post
Share on other sites
On 6/7/2019 at 8:19 AM, BladesMaster said:

Hi,

I've just generated my certificates with lego (interface to Let'sEncrypt)

Please explain, how to do this with qpkg package:

 

To enable HTTPS, you need to configure the ROCKET_TLS.

The values to the option must follow the format:


ROCKET_TLS={certs="/path/to/certs.pem",key="/path/to/key.pem"}

Where:

  • certs: a path to a certificate chain in PEM format
  • key: a path to a private key file in PEM format for the certificate in certs

docker run -d --name bitwarden \
  -e ROCKET_TLS='{certs="/ssl/certs.pem",key="/ssl/key.pem"}' \
  -v /ssl/keys/:/ssl/ \
  -v /bw-data/:/data/ \
  -p 443:80 \
  bitwardenrs/server:latest

First of all, you will need to know the path to your certficate files. If you are using QTS SSL Certificate (Lets Encrypt integrated with QTS DDNS / CloudLink), you will find your certificate and key in the following path...

/mnt/HDA_ROOT/.config/QcloudSSLCertificate/cert/cert

/mnt/HDA_ROOT/.config/QcloudSSLCertificate/cert/cert/key

Presuming you have the Bitwarden qpkg installed, open the Bitwarden.sh file located at..

/opt/BitWarden/

Add the ROCKET_TLS declarations like so...

#!/bin/sh
CONF=/etc/config/qpkg.conf
QPKG_NAME="BitWarden"
QPKG_ROOT=`/sbin/getcfg $QPKG_NAME Install_Path -f ${CONF}`
APACHE_ROOT=`/sbin/getcfg SHARE_DEF defWeb -d Qweb -f /etc/config/def_share.info`

ROCKET_TLS={certs="/mnt/HDA_ROOT/.config/QcloudSSLCertificate/cert/cert",key="/mnt/HDA_ROOT/.config/QcloudSSLCertificate/cert/key"}
export QNAP_QPKG=$QPKG_NAME

export QPKG_ROOT
export QPKG_NAME
export APACHE_ROOT

export ROCKET_TLS

export HOME=$QPKG_ROOT
export SHELL=/bin/sh
export LC_ALL=en_US.UTF-8
export USER=admin
export LANG=en_US.UTF-8
export LC_CTYPE=en_US.UTF-8
export TZ=$(/sbin/getcfg System 'Time Zone' -f /etc/config/uLinux.conf)


Save the file, then Stop and Start Bitwarden from the AppCenter. Presuming your certificate paths are correct, and in the correct format, Bitwarden should be available on https://<your certificate name>:8000

FYI... I am in no way a linux guru. I figured this out with a little linux knoweldge, a dash of google-fu, and a generous helping of common sense. If you have problems, experiement and reserach a little.

 

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.11.0

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.11.0

Share this post


Link to post
Share on other sites

Hey guys,

I'm a newby but i tried to find this file :

"

Presuming you have the Bitwarden qpkg installed, open the Bitwarden.sh file located at..

/opt/BitWarden/"

using ssh or file zilla but without any success! i received a message that this directory doesn't exist. For the record i've installed the bitwarden qpkg from qnapclub. it runs normally, but i'd like to follow yours instructions to use https like above.

Some help please?

Thanks

Share this post


Link to post
Share on other sites
19 hours ago, Hubby972 said:

Hey guys,

I'm a newby but i tried to find this file :

"

Presuming you have the Bitwarden qpkg installed, open the Bitwarden.sh file located at..

/opt/BitWarden/"

using ssh or file zilla but without any success! i received a message that this directory doesn't exist. For the record i've installed the bitwarden qpkg from qnapclub. it runs normally, but i'd like to follow yours instructions to use https like above.

Some help please?

Thanks

What model of QNAP do you have?

Share this post


Link to post
Share on other sites

My qnap is a Ts 453 A, but fine  I find this file and I could modificateur it. But when I tried to reach the server with the domain name ( my domain.myqnapcloud.com:8000) the server can’t be found. I have followed all your instructions but not have success. Do you have an idea?

Do I have to play this part on a terminal command with the qpkg installation of Bitwarden ? If yes when and how?

 » 

docker run -d --name bitwarden \
  -e ROCKET_TLS='{certs="/ssl/certs.pem",key="/ssl/key.pem"}' \
  -v /ssl/keys/:/ssl/ \
  -v /bw-data/:/data/ \
  -p 443:80 \
  bitwardenrs/server:latest

thanks for helping

 

I forgot to tell that I can reach the server using a local address ip like https://178.123.1.123:8000 but when I tried with the domain name like my domain.myqnapcloud.com :8000 it doesn’t work. I have tried with my phone with the bitwarden app, also with an ipad and a pc on windows. Any clue?

 

Share this post


Link to post
Share on other sites

ok! find by myself and everything is ok now! works great.

But i have an issue : i'm unable to receive the verification mail. it seems that i should configure a file with the hostmane of my domain. is anyone knows the file to modificate and where i can find it ?

thanks

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.12.0

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.12.0

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.13.0

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.13.0

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 1.13.1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×