Jump to content
  • 0
laffreux

comment avoir un .htaccess simple avec QNAP 109

Question

Je voudrais avec l'utilisation de .htaccess restreindre l'accès aux pages web situées dans Qweb aux seules personnes identifiées avec leur mot de passe.

J'ai donc suivi la procédure indiquée par jogul dans la page suivante : http://forum.qnap.com/viewtopic.php?f=32&t=421&p=75971

Avec winSCP j'ai procédé aux modifications indiquées.

Dans le répertoire Qweb j'ai mis un fichier .htaccess avec les lignes suivantes :

AuthUserFile /share/HDA_DATA/Qweb/qnappwd.txt

AuthGroupFile /dev/null

AuthName "Accès sécurisé au site QWEB de mon QNAP 109"

AuthType Basic

Require valid-user

et dans qnappwd.txt, j'ai la ligne suivante :

login:motdepasse

Et bien rien !

Je précise que j'ai également essayé avec la ligne suivante dans .htaccess

AuthUserFile /share/HDA_DATA/Qweb/qnappwd.txt

ou encore avec en lieu et place de qnappwd.txt .htpasswd, rien n'y a fait ...

J'accède à la page index sans demande d'identification.

Auriez-vous un moyen simple de mise en oeuvre de .htaccess à m'indiquer ?

Où ai-je fais une erreur ?

Merci de me venir en aide au plus vite.

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Bonjour,

Avez-vous bien mis le AllowOverwrite dans apache.conf et re démarré apache : /etc/init.q/Qthttpd.sh restart ???

Philippe.

Share this post


Link to post
Share on other sites
  • 0

il faut modifier dans la config d'apache, par défaut, les htaccess ne sont pas supportés.

AllowOverride All

si je me souviens bien dans le nas c'est none

Share this post


Link to post
Share on other sites
  • 0

Donc moi j'ai fais tout ce qui a été dis, la fenêtre avec la demande de login et mot de passe apparait bien, mais il me dit sans cesse que le login et mot de passe n'est pas bon. Le fichier qnappwd.txt se trouve bien dans le répertoire spécifié dans le .htaccess, mais rien à faire.

Une idée ???

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Donc moi j'ai fais tout ce qui a été dis, la fenêtre avec la demande de login et mot de passe apparait bien, mais il me dit sans cesse que le login et mot de passe n'est pas bon. Le fichier qnappwd.txt se trouve bien dans le répertoire spécifié dans le .htaccess, mais rien à faire.

Une idée ???

L'avez-vous créer avec htpasswd ? qui est dans : /usr/local/apache/bin

Philippe.

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Tu fais comment, j'arrive déjà pas à l'ouvrir !!!

Désolé du délai ... de réponse, je viens juste de récupérer ma connexion ...

Je n'ai que des souvenirs, car une fois insttallé ... mais les points important :

dans apache.conf la directive AllowOverwrite

Le fichier des password .htaccess ou autre doit être lisible par apache, donc dans le Qnap en "Read" pour "Other", puisque par défaut c'est l'utilisateur guest : guest qui exécute les taches pour apache.

Je crois qu'il est préférable dans le fichier .htaccess de n'utiliser que des chemins (Path) absolus (sans lien) donc par exemple

/share/HDA_DATA/Qweb/Mon_Rep/.htpasswd que /share/Qweb/Mon_Rep/.htpasswd (TBC)

Pour créer un fichier password ...

/usr/local/apache/bin/htpasswd -cb Chemin_jusqu'au_fichier_a crer user password

puis pour le remplir

/usr/local/apache/bin/htpasswd Chemin_jusqu'au_fichier_password user password

[~] # cd /usr/local/apache/bin/

[/usr/local/apache/bin] # ./htpasswd

Usage:

        htpasswd [-cmdpsD] passwordfile username

        htpasswd -b[cmdpsD] passwordfile username password


        htpasswd -n[mdps] username

        htpasswd -nb[mdps] username password

 -c  Create a new file.

 -n  Don't update file; display results on stdout.

 -m  Force MD5 encryption of the password.

 -d  Force CRYPT encryption of the password (default).

 -p  Do not encrypt the password (plaintext).

 -s  Force SHA encryption of the password.

 -b  Use the password from the command line rather than prompting for it.

 -D  Delete the specified user.

On Windows, NetWare and TPF systems the '-m' flag is used by default.

On all other systems, the '-p' flag will probably not work.

Voilà ... relancer Apache si changement dans la configuration

/etc/init.d/Qthttpd restart

Philippe.

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

J'ai moi aussi creer mon .htaccess

Ce qui ne fonctionne pas du tout c'est la regle de redirection en cas "401 errordocument"

La page web erreur se trouvant :

/share/HDA_DATA/Qweb/ErreurAcces.html

fichier .htaccess :

ErrorDocument 401 ErreurAcces.html

AuthUserFile /share/HDA_DATA/Qweb/qnappwd.txt

AuthGroupFile /dev/null

AuthName "Accès sécurisé au site QWEB de mon QNAP 109"

AuthType Basic


Require valid-user
J'ai ce message qui apparait :
Authorization Required This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.
Par contre si j'écris :
ErrorDocument 401 "Erreur !!!

AuthUserFile /share/HDA_DATA/Qweb/qnappwd.txt

AuthGroupFile /dev/null

AuthName "Accès sécurisé au site QWEB de mon QNAP 109"

AuthType Basic


Require valid-user

La si j'abandonne l'autentification ca fonctionne bien

le message "Erreur !!!" est ecrit.

Il a y a t'il une regle dans le fichier apache.conf qui empeche l'affichage en html d'un document errordocument ?

ou au contraire il faut rjouter une ligne pour que cette option fonctionne correctement ?

Merci de votre aide.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×