Jump to content
  • 0
internetgregory

Vitesse Upload/download Ftp Faible

Question

Bonjour à tous,

Je suis l'heureux possesseur d'un QNAP 219P branché sur mon réseau domestique (Neufbox de SFR, le QNAP relié en ethernet dessus, et 1 PC relié aussi sur la neufbox en filaire)...

De mon côté tout fonctionne très bien sauf le rajout d'un emplacement réseau depuis un PC extérieur sous Windows 7 (par exemple au bureau)... Le rajout d'un emplacement de type "http://monnom.dyndns.org/Public/#" me renvoi le message d'erreur "le dossier que vous avez entré ne semble pas être valide. Choisissez en un autre".

Pour palier à ce problème, je me connecte depuis l'extérieur en ftp et j'ai accès à mon NAS sans problème avec "ftp://monnom.dyndns.org/" et login et mot de passe.

Mais lorsque je fais des transfert de fichiers FTP depuis l'extérieur vers mon NAS je remarque des vitesses de transfert suivantes :

- En upload depuis mon PC extérieur vers mon NAS à la maison : 105 KB/s réel max

- En download depuis mon NAS vers mon PC extérieur : 115 KB/s réel max

Je trouve que ces valeurs sont très faibles ... est ce que j'ai loupé quelque chose dans la config du NAS ? (je précise que je n'ai mis aucune limitation FTP dans la config du NAS)

Avez-vous les mêmes valeurs que moi pour les vitesses d'upload et download depuis un ordi distant ?

Merci pour votre aide

PS: en local, mes vitesses sont de 5 MB/S réel pour du upload ou download sur le NAS... Avez vous pareil ?

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Bonjour,

Bonjour à tous,

Je suis l'heureux possesseur d'un QNAP 219P branché sur mon réseau domestique (Neufbox de SFR, le QNAP relié en ethernet dessus, et 1 PC relié aussi sur la neufbox en filaire)...

De mon côté tout fonctionne très bien sauf le rajout d'un emplacement réseau depuis un PC extérieur sous Windows 7 (par exemple au bureau)... Le rajout d'un emplacement de type "http://monnom.dyndns.org/Public/#" me renvoi le message d'erreur "le dossier que vous avez entré ne semble pas être valide. Choisissez en un autre".

Pour palier à ce problème, je me connecte depuis l'extérieur en ftp et j'ai accès à mon NAS sans problème avec "ftp://monnom.dyndns.org/" et login et mot de passe.

Mais lorsque je fais des transfert de fichiers FTP depuis l'extérieur vers mon NAS je remarque des vitesses de transfert suivantes :

- En upload depuis mon PC extérieur vers mon NAS à la maison : 105 KB/s réel max

- En download depuis mon NAS vers mon PC extérieur : 115 KB/s réel max

Je trouve que ces valeurs sont très faibles ... est ce que j'ai loupé quelque chose dans la config du NAS ? (je précise que je n'ai mis aucune limitation FTP dans la config du NAS)

Avez-vous les mêmes valeurs que moi pour les vitesses d'upload et download depuis un ordi distant ?

Merci pour votre aide

PS: en local, mes vitesses sont de 5 MB/S réel pour du upload ou download sur le NAS... Avez vous pareil ?

Sous windows 7 il y a un problème avec Webdav intégré à l'explorateur de fichier et QNAP, le Webdav Microsoft ne fonctionne bien qu'vace un serveur Web IS de Mrirosoft .

Utilisez une des alternatives gratuites genre Bitkinex (de plus il regroupe tout en un client FTP, SFTP et Webdav )

Pour vos débits, il faut connaitre votre accès de chaque coté ... car les accés ADSL (box) sont en général dissymétriques, donc avec un Internet -> PC élevé MAIS PC -> Internet (upload) très faible ...

Donc si vous en avez une à chaque bout ... vous serez limité par la bande passante en upload DANS CHAQUE SENS par l'un des deux accès.

Beaucoup de box ou un débit upload de 512 Koct/sec ... sachant qu'une session FTP (le protocole est comme ça) non parallélisée (genre download manager qui scinde en 4 et transfert les 4 morceaux en // ) utilise environ +- 1/4 de la bande passante ... vous obtenez un maximum de 512 / 4 = 128 Koct/sec si tout va bien ...

si vous ne faites que ça a un instant donné ... utilisez un download manager .... vous utiliserez au mieux votre bande passante.

Le Webdav pouvant dans certain cas être plus lent encore car en mode message et non flux ....

Philippe.

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Sous windows 7 il y a un problème avec Webdav intégré à l'explorateur de fichier et QNAP, le Webdav Microsoft ne fonctionne bien qu'vace un serveur Web IS de Mrirosoft .

Utilisez une des alternatives gratuites genre Bitkinex (de plus il regroupe tout en un client FTP, SFTP et Webdav )

Pour vos débits, il faut connaitre votre accès de chaque coté ... car les accés ADSL (box) sont en général dissymétriques, donc avec un Internet -> PC élevé MAIS PC -> Internet (upload) très faible ...

Donc si vous en avez une à chaque bout ... vous serez limité par la bande passante en upload DANS CHAQUE SENS par l'un des deux accès.

Beaucoup de box ou un débit upload de 512 Koct/sec ... sachant qu'une session FTP (le protocole est comme ça) non parallélisée (genre download manager qui scinde en 4 et transfert les 4 morceaux en // ) utilise environ +- 1/4 de la bande passante ... vous obtenez un maximum de 512 / 4 = 128 Koct/sec si tout va bien ...

si vous ne faites que ça a un instant donné ... utilisez un download manager .... vous utiliserez au mieux votre bande passante.

Le Webdav pouvant dans certain cas être plus lent encore car en mode message et non flux ....

Philippe.

Merci pour votre réponse !

Effectivement pour la connexion à distance, j'utilise le même genre que Bitkinex sous Windows 7 : Webdrive. Il me convient parfaitement mais payant.

Sinon pour les débit, OK la Neufbox doit brider l'upload de l'extérieur pour arriver à environ 105K/s... mais ce que je ne comprends pas c le débit lorsque que je récupère un fichier depuis le NAS, vers mon ordi distant (celui du bureau faisant parti d'un réseau d'entreprise donc avec des très fortes vitesses en download) qui est lui aussi d'environ 110 K/s... Ca vous parait élevé comme vitesse de téléchargement ?

De plus en réseau local, je trouve ça bizarre une vitesse de 5M/s max, non ? alors que sur des forums je vois des vitesse atteignant les 15M/s en écriture...

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Merci pour votre réponse !

Effectivement pour la connexion à distance, j'utilise le même genre que Bitkinex sous Windows 7 : Webdrive. Il me convient parfaitement mais payant.

Sinon pour les débit, OK la Neufbox doit brider l'upload de l'extérieur pour arriver à environ 105K/s... mais ce que je ne comprends pas c le débit lorsque que je récupère un fichier depuis le NAS, vers mon ordi distant (celui du bureau faisant parti d'un réseau d'entreprise donc avec des très fortes vitesses en download) qui est lui aussi d'environ 110 K/s... Ca vous parait élevé comme vitesse de téléchargement ?

De plus en réseau local, je trouve ça bizarre une vitesse de 5M/s max, non ? alors que sur des forums je vois des vitesse atteignant les 15M/s en écriture...

NON, mais il faudrait faire un test de ftp vers un site non bridé ou même un bittorent ... moi je teste avec le download d'un cd / dvd de debian ...

peut-être que votre entreprise a un QOS (limitation de débit) ou passe par un proxy transparent ou même a un très fort download et un upload (en sortie) plus faible ??? ....

Pour le local comme le distant : http://www.speedtest.net/ pour votre liaison internet ... et aussi tout en bas (cherchez dans le bandeau noir) speedtest mini qui s'installe dans /share/Web (ou Qweb) et permet un test local ... sachant que FTP pourrait potentiellement "sortir" environ 1/4 de ce débit ...

C'est un TRÈS bon test pour vérifier que votre réseau local et Internet fonctionne bien et au maximum ...

Philippe.

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

NON, mais il faudrait faire un test de ftp vers un site non bridé ou même un bittorent ... moi je teste avec le download d'un cd / dvd de debian ...

peut-être que votre entreprise a un QOS (limitation de débit) ou passe par un proxy transparent ou même a un très fort download et un upload (en sortie) plus faible ??? ....

Pour le local comme le distant : http://www.speedtest.net/ pour votre liaison internet ... et aussi tout en bas (cherchez dans le bandeau noir) speedtest mini qui s'installe dans /share/Web (ou Qweb) et permet un test local ... sachant que FTP pourrait potentiellement "sortir" environ 1/4 de ce débit ...

C'est un TRÈS bon test pour vérifier que votre réseau local et Internet fonctionne bien et au maximum ...

Philippe.

Sur vos conseils, j'ai donc installé speedtest mini dans le Qweb de mon Qnap et les resultats sont les suivants depuis mon PC distant (au bureau):

- Download : 910 Kbps

- Upload : 839 Kbps

Ce qui correspond bien au 110Ko/s notés précédemment en FTP... est ce correct ?

Share this post


Link to post
Share on other sites
  • 0

Je suis également bridé , et au courant de cette problématique avant d'avoir acheter mon Qnap étant chez neuf devenu SFR , il ne faut pas chercher la connexion est bridé par la box qui plus est dans un environnement non cablé comme je l'espère!

Càd : fibre optique !

attendre donc et prendre sont mal en patience !

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Sur vos conseils, j'ai donc installé speedtest mini dans le Qweb de mon Qnap et les resultats sont les suivants depuis mon PC distant (au bureau):

- Download : 910 Kbps

- Upload : 839 Kbps

Ce qui correspond bien au 110Ko/s notés précédemment en FTP... est ce correct ?

Je ne dirais pas correct ... mais constaté ... c'est un très bon indicateur, si possible il faudrait (pour votre connaissance propre) essayer depuis un autre point extérieur, cybercafé, ami etc ... pour voir la part qui vient de votre travail et celle du réseau Box + chez vous

essayez aussi en local cela vous donnera une idée de ce que votre Qnap et le réseau peuvent avoir comme performances ...

Il faut le prendre comme un indicateur ... qui vous rassure quand à votre configuration ...

vos résultats sont cohérent, donc malheureusement, vous ne pouvez espérer mieux sans changement de fournisseur.

Philippe.

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Je me permets de remonter ce sujet pour un problème similaire.

J'ai installé un TS-431U dans le but de créer un espace FTP pour les échanges de fichiers que nous faisons régulièrement avec l'extérieur.

Le soucis est que la bande passante en download depuis le QNAP vers un ordinateur extérieur (via le net donc) est limité à 110-115ko/s max, ce qui est loin du débit ascendant généralement constaté pour la connexion utilisée pour le QNAP (46-50Mb/s).

Ce qui est étrange, c'est que les transferts dans l'autre sens (ordi extérieur vers QNAP via le net) ne sont pas limités et se font aux débits max des connexions utilisées pour le transfert.

Pour info, le TS-431U est configuré en IP fixe et les ports lui sont bien redirigés depuis le routeur. D'ailleurs, en utilisant un ordinateur branché sur le réseau local, il n'y a aucune limite de bande passante si on utilise l'IP WAN.
Via le navgateur depuis un ordinateur sur le même réseau que le QNAP, si je tape ftp://ipWAN:port je peux télécharger à la vitesse max que me permet la connexion internet (environs 4,5Mo/s). En tapant ftp://ipLAN:port j'obtiens des débits correspondant au max possible sur mon réseau local (40 à 45Mo/s)
Depuis un ordinateur extérieur, avec ftp://ipWAN:port, je suis bridé à 110-115ko/s...

Merci d'avance pour votre aide.

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Je me trompe peut-être, ça fait longtemps que je n'ai pas joué avec ça  mais je crois que vous avez découvert le loopback.

Bien pratique pour tester les enregistrements externes au niveau des firewalls et routeurs, il ne permet pas cependant pas d'en tester les débits..

Autrement dit, vous avez testé un enregistrement d'adresse et de port sans sortir du réseau local, comme avec un switch sur le routeur. Aussi vous devriez regarder du côté des réglages du routeur, il y a de fortes chances que ce soit lui qui bride les connexions du côté WAN. A moins que ce ne soit pire, le FAI! Autrement dit, il faudrait tester un autre port...

Cordialement.

FredP

Share this post


Link to post
Share on other sites
  • 0

Bonjour Fred et merci pour la réponse.

Oui le loopback me permettait de tester que le problème de débit ne venait pas du QNAP lui même et que la connexion fonctionnait correctement. Par contre, je n'aurais pas pensé que les FAI puissent limiter la bande passante à ce point... J'espère que ce n'est pas ça sinon je l'ai dans l'os.

Pour le routeur, j'ai un peu épuisé toutes les options de configuration qui ne sont déjà pas nombreuses hormis la redirection des ports et leur déclenchement.

Je ferais un test sur une autre installation ayant le même fournisseur d'accès et je verrais bien si ça vient de là.

Au cas où y aurait-il d'autres pistes à explorer ?

 

Merci encore

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

L'idée du FAI est une idée comme une autre mais très très loin d'être forcément la bonne... Si votre routeur est une box, il est sûr qu'explorer les limites et configurations du routeur va être simple. D'ailleurs, qu'avez-vous comme type de connexion et débit Up/DL moyen? ADSL, VDSL2, Cable.. Les connexions asynchrones...?

Une autre piste à explorer? Assurez vous d'avoir bien activé le mode passif, essayez peut-être de forcer des taux de transferts en vitesses minimales et maximales. Les quotas sont définis par défaut. C'est donc 0 pour les firmares récents (4.3x) et 99999 pour les firmwares un peu plus vieux (4.2x).

Cordialement.

FredP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×