Jump to content
studio93

Client Openvpn

Recommended Posts

Bonjour,

Je m'adresse surtout a father_mande qui a packagé Openvpn pour nos QNAP.

Voila, j'ai installé tout cela, mais je me suis rendu compte que ce n'etait absolument pas ce qu'il me fallait :)

L'installation étant de type serveur, alors qu'il me faut juste la partie client.

Existe t-il la possibilité d'avoir un client pour le NAS 219P ?

En fait dans mon cas, c'est le NAS qui doit discuter en tant que client, avec openvpn en face.

Je ne trouve rien en ce sens.

Merci de votre aide.

Stud'

Share this post


Link to post
Share on other sites

Bonjour,

Bonjour,

Je m'adresse surtout a father_mande qui a packagé Openvpn pour nos QNAP.

Voila, j'ai installé tout cela, mais je me suis rendu compte que ce n'etait absolument pas ce qu'il me fallait :)

L'installation étant de type serveur, alors qu'il me faut juste la partie client.

Existe t-il la possibilité d'avoir un client pour le NAS 219P ?

En fait dans mon cas, c'est le NAS qui doit discuter en tant que client, avec openvpn en face.

Je ne trouve rien en ce sens.

Merci de votre aide.

Stud'

OUI, il suffit d'installer openvpn via ipkg (pas besoin du QPKG)

créez votre fichier de configuration, transférer vos clefs au moins ca.crt ... et ceux du client sauf si votre serveur travaille en mode user/password ; là il faut valider en lançant le client à la main (il vous pose la question) puis vous ajoutez le user et le password dans un fichier que vous pointez dans la configuration client client.ovpn .

Pour que openvpn soit en mode client il faut le mot clef client dans le fichier client.ovpn

généralement si vous êtes derrière un routeur ajoutez aussi la directive float

Philippe.

Share this post


Link to post
Share on other sites

Merci pour votre réponse !!

Cela parait simple comme cela, mais il y a des points obscure pour moi.

Normalement, lorsque je communique avec un serveur distant (Openvpn), je lance un soft sous mac (Tunneblick), il me demande mon User/password et le tunnel se fait.

OUI, il suffit d'installer openvpn via ipkg (pas besoin du QPKG)

En fait j'ai installé votre package directement par l'interface d'admin du nas, c'est ca ?

Share this post


Link to post
Share on other sites

Bonjour,

Ou alors ipkg c'est Optware ?

Car je l'ai installé aussi.

Tunneblick ... comme d'autre client n'est qu'un habillage graphique de la ligne de commande de openvpn. (pratique mais rend l'utilisateur 'avuegle' par rapport au produit)

Le QPKG openvpn Server s'installe en effet via l'administration menu QPKG ... il est inutile dans votre cas.

ipkg est en effet installé via le QPKG Optware

openvpn s'installe via ipkg par les commandes dans une console ssh ou telnet :

ipkg install openvpn

c'est en fait, ce que fait mon QPKG de manière invisible ... donc openvpn devrait être installé, si vous avez mis le QPKG

pour le faire fonctionner ...

recopiez votre fichier client .ovpn qui est dans le répertoire de tunneblick

recopier le ca.crt (sauf si il est inclus dans le fichier ovpn de configuration) .

tout ceci dans /opt/etc/openvpn

ajouter en début (si elle n'y est pas déjà) la directive client

ajouter la directive float

lancer votre client

/opt/sbin/openvpn --cd /opt/etc/openvpn --config client.ovpn

client.ovpn est un nom exemple vous utilisez celui donné ou celui de votre choix ... le .ovpn est aussi facultatif mais habituel pour un fichier client

là le système doit demander le user et le mot de passe ...

pensez à valider les logs ...

et :razz: lisez la documentation openvpn (options des clients et ligne de commande).

Philippe.

NB il existe plusieurs centaines de configurations possible avec openvpn ... donc pas de "pas à pas" mais il faut en apprendre les principes et usages.

Share this post


Link to post
Share on other sites

Wouah !

Expliqué comme cela je pense m'en sortir bien mieux !

Je commence en début d'aprem a distance.

Par contre, a partir de quel dossier faut-il installer le ipkg ?

J'imagine qu'il y a un endroit bien spécifique au lancement de l'install ?

Derniere chose, une fois tout cela installer, existe-il un moyen pour savoir si mon tunnel est fonctionnel ?

En général sur un ordi je lance un navigateur et je vais sur un site qui m'indique mon ip.

Mais dans le cas d'un nas ?

Merci beaucoup !

Share this post


Link to post
Share on other sites

Alors j'ai bien avancé grace a vous.

J'ai donc installé openvpn par ipkg

Celui ci ne fonctionnait pas alors qu'il était activé dans l'interface (????)

J'ai redémarré le serveur....

ipkg install openvpn

Erreur :( de cheksum ect...

ipkg update openvpn

OK !

Ensuite, j'ai lancé le client avec mes fichiers de conf ect..

Il me demande bien mon user / pass

Ensuite j'ai des erreurs, voici toutes les lignes suspectes, le reste a l'air impec !

Tue Feb 22 14:10:45 2011 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.

Tue Feb 22 14:10:45 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables

Tue Feb 22 14:10:46 2011 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this

Tue Feb 22 14:10:47 2011 WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1542', remote='link-mtu 1574'

Tue Feb 22 14:10:47 2011 WARNING: 'tun-mtu' is used inconsistently, local='tun-mtu 1500', remote='tun-mtu 1532'

Tue Feb 22 14:10:49 2011 Note: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)

Tue Feb 22 14:10:49 2011 Note: Attempting fallback to kernel 2.2 TUN/TAP interface

Tue Feb 22 14:10:49 2011 Cannot allocate TUN/TAP dev dynamically

Tue Feb 22 14:10:49 2011 Exiting

Il y a peut etre un port a redirigé pour le Nas ?

Il semble que le noyau TUN ne soit pas chargé, mais je ne sais pas ou le trouver ;(

Merci de votre aide.

Share this post


Link to post
Share on other sites

Bonjour,

Alors j'ai bien avancé grace a vous.

J'ai donc installé openvpn par ipkg

Celui ci ne fonctionnait pas alors qu'il était activé dans l'interface (????)

J'ai redémarré le serveur....

ipkg install openvpn

Erreur :( de cheksum ect...

ipkg update openvpn

OK !

Ensuite, j'ai lancé le client avec mes fichiers de conf ect..

Il me demande bien mon user / pass

Ensuite j'ai des erreurs, voici toutes les lignes suspectes, le reste a l'air impec !

Tue Feb 22 14:10:45 2011 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.

Tue Feb 22 14:10:45 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables

Tue Feb 22 14:10:46 2011 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this

Tue Feb 22 14:10:47 2011 WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1542', remote='link-mtu 1574'

Tue Feb 22 14:10:47 2011 WARNING: 'tun-mtu' is used inconsistently, local='tun-mtu 1500', remote='tun-mtu 1532'

Tue Feb 22 14:10:49 2011 Note: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)

Tue Feb 22 14:10:49 2011 Note: Attempting fallback to kernel 2.2 TUN/TAP interface

Tue Feb 22 14:10:49 2011 Cannot allocate TUN/TAP dev dynamically

Tue Feb 22 14:10:49 2011 Exiting

Il y a peut etre un port a redirigé pour le Nas ?

Il semble que le noyau TUN ne soit pas chargé, mais je ne sais pas ou le trouver ;(

Merci de votre aide.

NON, pas de port le qnap client ne fais que du sortant .... sauf si votre routeur filtre les ports sortant .... mais c'est le même qu'avec tunneblick .... donc si l'un fonctionne l'autre aussi (avec la même configuration)

OUI, il faut démarrer le tun.ko AVANT le lancement de openvpn ...

sur un 219 il est dans /lib/modules/others

faites un insmod /lib/modules/others/tun.ko

puis relancer

Philippe.

Share this post


Link to post
Share on other sites

ha mais lol il m'arrive un truc de dingue :)

Comme j'ai fait cela a distance, j'ai vu sur mon terminal que tout c'est bien passé et que le tunnel a été ouvert.

Sauf que j'ai perdu la connexion du coup entre chez moi et mon taf ^^ ou je faisais mes manips.

Share this post


Link to post
Share on other sites

Bonjour,

ha mais lol il m'arrive un truc de dingue :)

Comme j'ai fait cela a distance, j'ai vu sur mon terminal que tout c'est bien passé et que le tunnel a été ouvert.

Sauf que j'ai perdu la connexion du coup entre chez moi et mon taf ^^ ou je faisais mes manips.

Peut-être avez vous une option dans le fichier client.ovpn qui force TOUT le trafic du réseau via le vpn ...dans ce cas le qnap ne peut plus utiliser QUE le vpn et il faut donc s'y connecter via le serveur en back connect (si c'est possible)

pouvez-vous lister votre config .ovpn en enlevant que le nom dns du site cible et éventuellement le certificat ca si il est intégré ... comme nous n'avons ni votre user ni votre password ... pas de risque ...

bon par contre si c'est bien le forçage de tout le réseau ... et que vous ne pouvez vous connecter en back from server ... il va vous rester le reboot de la box (si possible) cela devrait tuer la connexion ... sauf auto reconnect ou bien pire des cas il faudra rebooter le qnap ...

même si vous étiez en local ... seul une console async via usb<->async vous permettrait de revenir en arrière ... sinon reboot aussi ...

Philippe.

il y a bien sur des solutions ... mais là les compétences réseau (routage) vont devenir un prérequis ...

Bonjour,

Bien sur il est possible qu'il (le vpn) ai laissé les configurations et route locales actives ... donc depuis un PC ou Mac sur le réseau local il sera peut-être possible d'ouvrir une session ssh ou telnet et de tuer (kill) openvpn ...

Philippe.

Share this post


Link to post
Share on other sites

J'ai récupéré l'ip qu'il avait attribué pour le tunnel (dans mon terminal avant que tout s'arrete)

Ensuite avec un soft tunnelier j'ai mis cette ip pour pouvoir connecter, ça répond bien et me propose un certificat mais le mot de passe est refusé, j'aurais tout vu :)

voici la conf demandé, j'ai enlevé les ips et le nom du cert, merci encore

client

float

dev tun

proto udp

remote-random

remote IP 1443

remote IP 1443

remote IP 1443

auth-user-pass

resolv-retry infinite

nobind

ca Cert.crt

verb 3

comp-lzo

Ce qui est fou c'est le mot de passe refusé :( (celui de mon nas)

Share this post


Link to post
Share on other sites

Bonjour,

J'ai récupéré l'ip qu'il avait attribué pour le tunnel (dans mon terminal avant que tout s'arrete)

Ensuite avec un soft tunnelier j'ai mis cette ip pour pouvoir connecter, ça répond bien et me propose un certificat mais le mot de passe est refusé, j'aurais tout vu :)

voici la conf demandé, j'ai enlevé les ips et le nom du cert, merci encore

client

float

dev tun

proto udp

remote-random

remote IP 1443

remote IP 1443

remote IP 1443

auth-user-pass

resolv-retry infinite

nobind

ca Cert.crt

verb 3

comp-lzo

Ce qui est fou c'est le mot de passe refusé :( (celui de mon nas)

Êtes vous sur que c'est bien le QNAP qui réponds ... ?

c'est déjà un plus si le serveur vpn autorise la retro connexion, usage d'une connexion depuis une adresse IP internet vers l'adresse IP attribué au Qnap client ...

avez-vous essayé avec d'autres ports 80 8080 etc. ...

avez-vous un mot de passe admin entrée sur clavier Français ... et que votre client ssh est Qwerty ???

Pourquoi utilisez-vous un tunnelier (c'est pour sortir de votre réseau professionnel ou pour autre chose ?) car si la retro connexion est possible, un simple client ssh vers l'adresse IP du vpn client et sur le port défini dans le Qnap devrait fonctionner ... ?

Philippe.

NB si ce n'est pas un secret quel fournisseur de VPN utilisez-vous ... cela pourrait être une aide pour comprendre ...

avez-vous gardé la trace du log lors de la connexion, surtout les push du server (gateway, dns, etc... )

Share this post


Link to post
Share on other sites

Bonsoir,

Oui j'utilisais un tunnelier car j'etais au travail et j'ai l'habitude de cela pour me connecter chez moi.

Hors la, j'avais passé le Nas et tous les services dessus en vpn en lançant le client openvpn.

Du coup je ne pouvais plus le choper en ssh comme d'ab.

Alors j'ai connecté de mon travail en vpn et j'ai pu joindre le nas, forcément j'était dans le tunnel.

Enfin je sais pas si je suis clair, j'ai du mal avec tout ce que j'ai avalé aujourd'hui ^^

Je suis passé par un site qui me donnait bien l'ip du nas au danemark.

En terminal j'ai fait un netstat -r et l'ip du danemark (donc attribué par le serveur vpn) était bien a la place de ma box, ou normalement j'ai une ip de mon FAI.

J'ai fait des tests comme avec la station de telechargement, et chekmytorrentip me sort bien l'ip du serveur du danemark a la place de mon ip Francaise...

J'espere que j'ai bien vu en face des trous...

Mais, meme si cela me parait correct, je ne cesse de faire du netsat pour voir si mon ip n'a pas changé ^^ c'est mon coté parano.

C'est pas très souple le terminal quand on ne connais pas grand chose ^^

A chaque reboot NAS ça va etre coton, va faloir que je me casse la tete pour lancer cela a la mano.

Share this post


Link to post
Share on other sites

Bonsoir,

Bonsoir,

Oui j'utilisais un tunnelier car j'etais au travail et j'ai l'habitude de cela pour me connecter chez moi.

Hors la, j'avais passé le Nas et tous les services dessus en vpn en lançant le client openvpn.

Du coup je ne pouvais plus le choper en ssh comme d'ab.

Alors j'ai connecté de mon travail en vpn et j'ai pu joindre le nas, forcément j'était dans le tunnel.

Enfin je sais pas si je suis clair, j'ai du mal avec tout ce que j'ai avalé aujourd'hui ^^

Je suis passé par un site qui me donnait bien l'ip du nas au danemark.

En terminal j'ai fait un netstat -r et l'ip du danemark (donc attribué par le serveur vpn) était bien a la place de ma box, ou normalement j'ai une ip de mon FAI.

J'ai fait des tests comme avec la station de telechargement, et chekmytorrentip me sort bien l'ip du serveur du danemark a la place de mon ip Francaise...

J'espere que j'ai bien vu en face des trous...

Mais, meme si cela me parait correct, je ne cesse de faire du netsat pour voir si mon ip n'a pas changé ^^ c'est mon coté parano.

C'est pas très souple le terminal quand on ne connais pas grand chose ^^

A chaque reboot NAS ça va etre coton, va faloir que je me casse la tete pour lancer cela a la mano.

Une fois sur que ce qui est ... est bien ce que vous voulez ... il sera possible d'automatiser le lancement sans passer par la console ...

Philippe.

Share this post


Link to post
Share on other sites

Bonjour,

Donc hier tout c'est bien passé, j'ai fait des tests très tard.

Ce matin j'ai du relancé Tun a la mano, ainsi que le client openvpn.

L'idéal serait de faire un fichier pour lancer le tout.

J'essaye en ce moment de kill openvpn mais cela me dit que ce job n'est pas valid.

Je vais faire un peut de recherche...

C'est excitant les premiers pas en terminal :)

Sauf que j'essaye des commandes UNIX non reconnu par le NAS (comme la commande jobs), ca commence bien ^^

-sh: kill: `openvpn': not a pid or valid job spec

Meme si je prends le PID de :

4456 admin 3020 S /opt/sbin/openvpn --cd /opt/etc/openvpn --config Denmark.conf

ca donne rien non plus j'ai le meme message.

Une aide serait vraiment sympatique :) J'écume le net et je ne trouve pas comment kill le client.

Edited by studio93

Share this post


Link to post
Share on other sites

Bonjour,

Bonjour,

Donc hier tout c'est bien passé, j'ai fait des tests très tard.

Ce matin j'ai du relancé Tun a la mano, ainsi que le client openvpn.

L'idéal serait de faire un fichier pour lancer le tout.

J'essaye en ce moment de kill openvpn mais cela me dit que ce job n'est pas valid.

Je vais faire un peut de recherche...

C'est excitant les premiers pas en terminal :)

Sauf que j'essaye des commandes UNIX non reconnu par le NAS (comme la commande jobs), ca commence bien ^^

-sh: kill: `openvpn': not a pid or valid job spec

Meme si je prends le PID de :

4456 admin 3020 S /opt/sbin/openvpn --cd /opt/etc/openvpn --config Denmark.conf

ca donne rien non plus j'ai le meme message.

Une aide serait vraiment sympatique :) J'écume le net et je ne trouve pas comment kill le client.

killall a la différence de kill prends le nom de l'exécutable et non son pid ...

kill fonctionne, mais il faut lui donner le type de signal ...

le "mortel" est :

kill -9 pid

pour une fermeture propre

kill -15 pid

le kill fourni étant celui de busybox, il est incomplet le "full fonctionnal" intègre la possibilité de demander le pid d'un process ;...

Philippe.

NB pour le lancement automatique regardez vers autorun.sh ... mais attention d'attendre que Optware soit en place ... (tutoriels et FAQ)

Share this post


Link to post
Share on other sites

Bonjour,

Je vais essayer vos recommandations, même si j'avoue ne pas avoir tout compris.

dans l'exemple : kill -15 pid

le -15 étant le numéro dépendant de :

4456 admin 3020 S /opt/sbin/openvpn --cd /opt/etc/openvpn --config Denmark.conf

donc kill -4456 pid

(??)

Pour la procédure auto, est-il possible d'utiliser daemon_mgrd ou rien a voir ?

J'ai cru voir passer une info en ce sens.

En fait j'ai besoin de :

Charger TUN

Lancer le client

Renseigner le login / pass

C'est hard

PS : Optware est dèjà installé.

RPS : J'ai trouvé un Tuto de vous alors ça va m'aider beaucoup !!

RE : houalala c'est bouillant ^^ l'article, la je crois que je vais m'arrêter ;(

Edited by studio93

Share this post


Link to post
Share on other sites

Re,

Bien bien, j'ai lu et relu votre tuto concernant l"exécution de scripts, et même le wiki en anglais.

J'ai compris certaines choses (je dormirais moins bete ce soir ;) ) et d'autres me semble encore obscures.

J'ai bien saisie pour moi l'avantage d'avoir un script modifiable appelé par autorun.sh dans le cas ou j'ai besoin de changer le nom de fichier .conf du serveur.

Ceci sans avoir a remounted et éditer autorun.sh

Il me reste encore beaucoup de chemin a parcourir, halala ou est le temps du dos batch ;)

J'ai encore des interrogations notamment comment passer les valeurs login/pass dans un script/shell ? pour qu'il réponde à la question a ma place.

Bref, je pensais avoir fait le plus compliqué, réellement ^^

Je me rends compte que le plus compliqué n'est pas d'installer tout le fourbi et que cela fonctionne, mais de faire en sorte a ce que ça démarre tout seul ect...

court allumer un cierge.

PS : il n'existe pas un automator Wisiwing sous forme de QPKG comme Q-Ext ?

Share this post


Link to post
Share on other sites

Bonjour,

Re,

Bien bien, j'ai lu et relu votre tuto concernant l"exécution de scripts, et même le wiki en anglais.

J'ai compris certaines choses (je dormirais moins bete ce soir ;) ) et d'autres me semble encore obscures.

J'ai bien saisie pour moi l'avantage d'avoir un script modifiable appelé par autorun.sh dans le cas ou j'ai besoin de changer le nom de fichier .conf du serveur.

Ceci sans avoir a remounted et éditer autorun.sh

Il me reste encore beaucoup de chemin a parcourir, halala ou est le temps du dos batch ;)

J'ai encore des interrogations notamment comment passer les valeurs login/pass dans un script/shell ? pour qu'il réponde à la question a ma place.

Bref, je pensais avoir fait le plus compliqué, réellement ^^

Je me rends compte que le plus compliqué n'est pas d'installer tout le fourbi et que cela fonctionne, mais de faire en sorte a ce que ça démarre tout seul ect...

court allumer un cierge.

PS : il n'existe pas un automator Wisiwing sous forme de QPKG comme Q-Ext ?

réponses au 1er message

kill -9 est équivalent à kill -KILL qui envoie SIGKILL au pid du programme a tuer

il faut écrire

kill -9 4456

ou

kill -KILL 4456

pour envoyer terminer SIGTERM c'est

kill -15 4456

ou

kill -TERM 4456

il ya une quinzaine de SIG .....

Daemon_mgr sert en effet à lancer un programme et le surveille, en cas de crash de celui-ci, daemon_mgr le relance et poste un log : relaunch : process_name

ATTENTION il faut aussi stopper votre processus par daemon-mgr sinon celui-ci relancera le programme ...

vous pouvez le l'utiliser dans un autorun.sh

pour renseigner le login/password il existe une option de openvpn ... vous ajoutez un nom de fichier à la directive :

auth-user-pass file_name

avec en clair le user et le mot de passe sur 2 lignes, mais je ne sais si cela a été implémenté par les gens ayant fait le portage sous ipkg ???

essayez

sinon il faudra utiliser une simple redirection d'entrée dans votre shell ...

NON c'est pas compliqué, c'est du travail d'administrateur, vous forcez le QNAP a faire ce pourquoi il n'a pas été généré à la base ...

Le VPN est une fonction réseau pas NAS ...

Si vous sortez du champs d'application "normal" il faut savoir ce que vous faites ... :roll::razz:

Il pourrait exister un lanceur, mais il ne pourrait pas faire les scripts à votre place ....B)

Philippe.

Share this post


Link to post
Share on other sites

Bonjour Philippe, et merci encore pour votre aide précieuse.

En effet pour la fonction KILL, j'avais bien vu que je m'était embrouillé, pour avoir essayé plusieurs solutions dans l'ordre et le désordre.

En fait j'évite d'essayer sans aide précise pour ne pas casser quelque chose, et puis les exemples sur le net changent en fonction de la distrib ou je ne sais quoi, qui fait que tout ce que je lis ici ne correspond en rien a ce que je lis sur le net en cherchant mes mots clés.

Bref, en trifouillant, j'avais planté le NAS a distance 2 fois, heureusement que ma femme était présente pour le relancer.

Je vais rassembler les infos ici et voir si je peux trouver quelqu'un pour me faire le fichier qui va renseigner l'autorun.sh

J'ai compris la procédure pour mounted la partoche, ainsi que comment faire l'autorun.sh s'il n'existe pas et le rendre executable, c'est le reste que je ne comprends pas, comme par exemple lancer TUN et le client dans le sens ou cela ne doit pas se faire comme sous terminal directement (?) :

Merci encore

-------------

cd /lib/modules/others/

insmod tun.ko

/opt/sbin/openvpn --cd /opt/etc/openvpn --config Denmark.conf

Puis... entrer le login/pass

-------------

Share this post


Link to post
Share on other sites

Rebonjour Philippe,

Savez-vous si en cas de micro coupure du coté serveur, le client lui, sait renégocier pour récupérer une nouvelle ip.

Car mon tunnel a bien fonctionné plusieurs heures mais ce matin il ne répondait plus.

Reboot puis nouvelle ip et c'est OK.

Je sais que si j'utilise un client soft sous mac en cas de coupure, il re négocie, mais dans le cas de openvpn en client ?

Merci d'avance.

Share this post


Link to post
Share on other sites

Bonjour,

Rebonjour Philippe,

Savez-vous si en cas de micro coupure du coté serveur, le client lui, sait renégocier pour récupérer une nouvelle ip.

Car mon tunnel a bien fonctionné plusieurs heures mais ce matin il ne répondait plus.

Reboot puis nouvelle ip et c'est OK.

Je sais que si j'utilise un client soft sous mac en cas de coupure, il re négocie, mais dans le cas de openvpn en client ?

Merci d'avance.

essayez d'ajouter dans le fichier de configurtion .ovpn les directives

persist-key

persist-tun

Le problème peut venir du changement d'adresse externe de votre box ADSL ...

ou bien de la non sauvegarde des user et password ... avez-vous essayé avec le fichier à la place de l'entrée manuelle ? je ne sais pas en fait si le user et mot de passe est sauvegardé en 2.1.4 ????

Les clients évolués, comme il lance eux-même la connexion peuvent en assurer le suivi et garde le user et password ....

ajoutez les logs (puisque je pense que vous n'avez pas l'administration du serveur, qui si j'ai compris doit être un pourvoyeur de service vpn ?)

log-append /opt/etc/openvpn/logvpn.log

sinon, il faudra essayer de créer un batch de surveillance.

ou un cron qui relancera openvpn chaque nuit vers 3h00 heure ou généralement les adresses ADSL des box ont changé ...

Philippe.

Share this post


Link to post
Share on other sites

Merci pour les commandes.

Aucune n'etaient présente dans mon fichier de conf.

Je n'ai pas de log, maintenant je verrais mieux.

qui si j'ai compris doit être un pourvoyeur de service vpn ?
Oui c'est exact En fait je pense savoir ce qu'il c'est passé pour que je perde la connexion. J'ai le droit de me connecter avec autant de client que je veux, mais a partir d'un meme site. Hors, j'ai voulu me connecter d'un site B pour joindre le tunnel, alors que le NAS est en site A. La supervision du prestataire de service VPN a du Killer l'ancienne connexion (site A) pour laisser passer la nouvelle, celle que j'ouvrais sur le site B. Grrrr Si je met ce code dans un shell qui sera appelé par mon autorun.sh cela fonctionnerait ?
/sbin/daemon_mgr openvpn_client start "/opt/sbin/openvpn --daemon --cd /opt/etc/openvpn --config Denmark.conf"

Share this post


Link to post
Share on other sites

Bonjour,

Merci pour les commandes.

Aucune n'etaient présente dans mon fichier de conf.

Je n'ai pas de log, maintenant je verrais mieux.

qui si j'ai compris doit être un pourvoyeur de service vpn ?
Oui c'est exact En fait je pense savoir ce qu'il c'est passé pour que je perde la connexion. J'ai le droit de me connecter avec autant de client que je veux, mais a partir d'un meme site. Hors, j'ai voulu me connecter d'un site B pour joindre le tunnel, alors que le NAS est en site A. La supervision du prestataire de service VPN a du Killer l'ancienne connexion (site A) pour laisser passer la nouvelle, celle que j'ouvrais sur le site B. Grrrr Si je met ce code dans un shell qui sera appelé par mon autorun.sh cela fonctionnerait ?
/sbin/daemon_mgr openvpn_client start "/opt/sbin/openvpn --daemon --cd /opt/etc/openvpn --config Denmark.conf"

Le code fonctionnera uniquement si Optware est bien démarré hors les QPKG (tous) sont démarré APRÈS l'autorun.sh

donc utilisez une des méthodes suggérés

wait en background

attente de l'arrivée de /tmp/.boot_done qui indique que tout est lancé (système + QPKG) toujours en background (autorun.sh lance lui-même un shell avec & à la fin )

attention aussi que /opt/bin et /opt/sbin ne sont ajoutés au Path qu'après le lancement de Optware ....

donc il faut le forcer dans votre shell

export PATH=$PATH:/opt/bin:/opt/sbin

LISEZ bien les tutoriels ....

Philippe.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×