Jump to content
sebelec

Transmission 2.22 Et Proxy

Recommended Posts

Bonjour à tous,

j'utilise transmission depuis plus d'1 an maintenant avec mon QNAP TS 210. J'avais transmission 2.03 configuré avec un proxy socks5. Et tout marché bien comme dans le monde des bisounours.

Mais j'ai hélas du mettre à jour mon transmission avec la derniére version (2.22) et maintenant transmission ne prends plus en compte les paramètres proxy que j'intègre dans le fichier settings.json

J'utilise checkmytorrentip.com pour connaitre l'ip utilisé par transmission et c'est à chaque fois l'ip de ma connexion. Je ne comprends pas car j'ai bien le proxy activé. Voici mon setting.json :

"proxy": "torrentproxy.dontexist.org", 

    "proxy-auth-enabled": true, 

    "proxy-auth-password": "*************", 

    "proxy-auth-username": "sebelec", 

    "proxy-enabled": true, 

    "proxy-port": 80, 

    "proxy-type": 2, 

J'ai deux possibilités qui s'offre à moi, soit par miracle le problème est connu et quelqu'un ici pourra m'aider, soit il faudrait que je retourne en version 2.03 mais je ne sais absolument pas comment faire, je ne trouve pas de qpkg de la version 2.03

Merci à vous !

Share this post


Link to post
Share on other sites

Bonjour,

Bonjour à tous,

j'utilise transmission depuis plus d'1 an maintenant avec mon QNAP TS 210. J'avais transmission 2.03 configuré avec un proxy socks5. Et tout marché bien comme dans le monde des bisounours.

Mais j'ai hélas du mettre à jour mon transmission avec la derniére version (2.22) et maintenant transmission ne prends plus en compte les paramètres proxy que j'intègre dans le fichier settings.json

J'utilise checkmytorrentip.com pour connaitre l'ip utilisé par transmission et c'est à chaque fois l'ip de ma connexion. Je ne comprends pas car j'ai bien le proxy activé. Voici mon setting.json :

"proxy": "torrentproxy.dontexist.org", 

    "proxy-auth-enabled": true, 

    "proxy-auth-password": "*************", 

    "proxy-auth-username": "sebelec", 

    "proxy-enabled": true, 

    "proxy-port": 80, 

    "proxy-type": 2, 

J'ai deux possibilités qui s'offre à moi, soit par miracle le problème est connu et quelqu'un ici pourra m'aider, soit il faudrait que je retourne en version 2.03 mais je ne sais absolument pas comment faire, je ne trouve pas de qpkg de la version 2.03

Merci à vous !

Proxy n'est plus supporté depuis la 2.12 : https://trac.transmissionbt.com/ticket/3817

Il faut donc, je pense, revoir votre configuration ....

A priori, transmission utilise maintenant les proxy de l'os, il doit donc être nécessaire de passer via les variables d’environnement http_proxy a déclarer dans le shell de lancement ...

Analyse par défaut, car je n'utilise pas transmission ...

Philippe.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×