Jump to content
  • 0
exeo-solutions

Rsync D'un Nas Vers Un Autre Nas

Question

Bonjour tout le monde,

Config : 2 NAS TS-410 avec last firmware

2 soucis :

#1 :

J'ai une série de dossiers dans un dossier parent ( \perso ) , chaque dossier se nomme avec un nom d'utilisateur, ex : \perso\user1 , \perso\user10 )

Une dizaine de dossier perso comme ca, mon soucis est que en Rsync en local sur le meme NAS le dossier de destination se mélange les pinceaux sur les droits...

je m'explique :

Source : \perso\user1,....\perso\user10

Chaque user a le droit sur son dossier

Destination :

\SaveLundi\user1,...\SaveLundi\user10

\SaveMardi\user1,...\SaveMardi\user10

etc...

etc...

Le soucis est que sur plusieurs dossiers de destination les droits sont ( j'ai l'impression ) décalé

Mon dossier \SaveMardi\User4 à pour seul personne en accés User5 , alors que dans le dossier source \Perso\User4 à pour utilisateur User4 et non pas User5.

En fait les droits de certains dossiers ne sont pas 'rsync' dans le dossier de destination...

#2 :

Mon 2nd soucis, est que en Rsync du NAS1 vers le NAS2, je me retrouve avec des dossiers vides dans mon NAS2.

Exemple :

Nas1\Perso\User1\

Archivemails\

Dossier1\

Dossier2\Dossier2x

Dossier3\

et

Nas2\Perso\User1\

Dossier1\

Dossier3\

Je me retrouve avec des dossiers vides dans mon NAS de destination, et de facon aléatoire...cetains user aucun souci d'autre aucun dossier...( meme config etc..etc...)

Une idée??

Merci !!!!!!!!!

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Bonjour,

... :shock: ...

Beuhhhh !!!! :???: ...

1 ) essayer bien sur le support (je n'ai pas "vu" de bug ... mais ... )

2 ) avez vous les deux NAS avec ou sans ACL ... mais pas l'un sans l'autre ???

3 ) avez-vous fait une copie initiale ... un tar (par ex.) + transfert + untar pour être sur que les droits de base sont bien transcris.

4 ) êtes-vous sur que les UID (pas les noms c'est juste pour mieux lire) de vos users sont bien identiques ; comparez les fichier /etc/passwd des 2 cotés ...

car pour conserver les droits users, il ne faut pas des NOMS identiques mais des UID premier chiffre après le nom utilisateur identique.

... bon je tape peut-être dans le vide (vous aviez déjà vérifié tout ça ? ... ) ... mais c'est quand même si étrange comme erreur ...

Philippe.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×