Jump to content
  • 0
toucher

Synchro De Base De Données Xbmc Sur Un Ts-269L

Question

Bonjour à tous !

Je galère depuis plus d'une semaine à essayer de synchronisé
ma base de données xbmc via MySQL avec le TS-269L sur 2 clients Windows 7 et un RasPI.

Je dois avoir lu + de 150 pages sur le sujet, mais rien n'y fait !

Mon problème se situe vraiment au niveau du QNAP (en Local) qui n'arrive pas à se connecter
au serveur MySQL local et d'y créer sa base de données. J'ai réussi à le faire via
une station Windows qui se connecte au serveur SQL du NAS et ça fonctionne parfaitement.

Le xbmc sur Windows arrive à créer sa base de données sans problème.

Lorsque je lance mon xbmc du NAS, il m'affiche une erreur de communication au serveur distant,
erreur de lancement.

Voici le contenu de mon fichier de config advancedcedsettings.xml

<advancedsettings>
<videodatabase>
<type>mysql</type>
<host>192.168.0.90</host>
<port>3306</port>
<user>xbmc</user>
<pass>xbmc</pass>
<name>xbmc_video</name>
</videodatabase>
<videoscreen>
<screen>0</screen>
</videoscreen>
<cputempcommand>sed -e 's/000/ C/' /sys/class/hwmon/hwmon0/device/temp1_input</cputempcommand>
<gputempcommand>sed -e 's/000/ C/' /sys/class/hwmon/hwmon0/device/temp1_input</gputempcommand>
<pathsubstitution>
<substitute>
<from>special://masterprofile/Thumbnails/</from>
<to>smb://xbmc:xbmc@192.168.0.90/Multimedia/FILMS/Thumbnails/</to>
</substitute>
</pathsubstitution>

</advancedsettings>

L'utilisateur xbmc a été créer dans MySQL avec toutes les permissions appropriées (car ça fonctionne
à partir de Windows) et aussi un utilisateur xbmc as aussi été créer avec p.w. xbmc sur le NAS avec
les permissions r/w sur le partage Multimedia. Dans la balise host, j'ai essayé (localhost ou 127.0.0.1) sans succès

Tous mes clients xbmc ont la même version, la 6 et le NAS carbure sous la QTS 4.0.3

Si quelqu'un peut m'aider à résoudre mon bug, il me feras un grand plaisir de pondre un tutorial
et de le rendre disponible sur le forum.

 

Merci de m'avoir lu,

Salutation

Toucher

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Bonjour,

 

1 Votre base est-elle visible via phpMyAdmin ?, la création (à priori) par Xbmc est connu pour ne pas fonctionner suivant les versions de Mysql

2 Xbmc ... tourne dans un chroot (Ubuntu 12.04), il "voit" donc la base MySQL via le réseau 127.0.0.1 (puisque sur la même machine) ou IP_du_NAS PAS avec localhost (erreur connue)

... il n'y a donc PAS à créer le moindre utilisateur dans le QNAP MAIS seulement dans la base Mysql

3 cet utilisateur doit avoir des droits spécifiques pour le QNAP : NE PAS UTILISER % pour indiquer TOUS les hosts ...

4 malheureusement (pour nous) la réécriture de l'interface MySQL n'intervient qu'avec la version 12 ... non disponible ... suite aux problèmes spécifiques au driver INTEL sur les x69 (driver propriétaire, sur lequel QNAP ne peut intervenir (binaires) et donc doit attendre le bon vouloir de Intel )

 

... une petite remarque si le QNAP est bien le .90 utiliser smb pour accéder à une ressource qui est directement accessible (/share/Multimedia) c'est ajouter une "couche" pour rien ...

 

Bon courage, car nombreux (et pas que sur QNAP) sont ceux qui en ont sué pour réussir ... le duo Xbmc / Mysql

 

Philippe.

Share this post


Link to post
Share on other sites
  • 0

Bonjour, Philippe

 

Yahooooo je viens de réussir !!!

 

Maudit que suis content, après 30 ou 40 heures d'essais / erreurs et de recherche.

J'ai gardé exactement le même script sauf l'adresse IP du serveur MySQL, j'ai branché la 2e interface réseau sur le NAS, configurer en IP fixe sur 192.168.0.91

et BINGO !!!

 

 

1 Votre base est-elle visible via phpMyAdmin ?, la création (à priori) par Xbmc est connu pour ne pas fonctionner suivant les versions de Mysql

 

oui absolument

 

2 Xbmc ... tourne dans un chroot (Ubuntu 12.04), il "voit" donc la base MySQL via le réseau 127.0.0.1 (puisque sur la même machine) ou IP_du_NAS PAS avec localhost (erreur connue)

... il n'y a donc PAS à créer le moindre utilisateur dans le QNAP MAIS seulement dans la base Mysql

 

L'utilisateur xbmc est la pour le partage réseau des autres clients, windows et linux.

 

3 cet utilisateur doit avoir des droits spécifiques pour le QNAP : NE PAS UTILISER % pour indiquer TOUS les hosts ...

 

Je sais.

 

4 malheureusement (pour nous) la réécriture de l'interface MySQL n'intervient qu'avec la version 12 ... non disponible ... suite aux problèmes spécifiques au driver INTEL sur les x69 (driver propriétaire, sur lequel QNAP ne peut intervenir (binaires) et donc doit attendre le bon vouloir de Intel )

 

... une petite remarque si le QNAP est bien le .90 utiliser smb pour accéder à une ressource qui est directement accessible (/share/Multimedia) c'est ajouter une "couche" pour rien ...

 

Selon ce que j'ai lu dans mes recherches ils sont tous configurés comme ça, c'est le même fichier .XML qui est copier sur tous les clients: Win, Linux ou autres.

 

Bon courage, car nombreux (et pas que sur QNAP) sont ceux qui en ont sué pour réussir ... le duo Xbmc / Mysql

Philippe.

 

Encore une fois merci pour tes précieux conseils. La semaine prochaine je vais entreprendre la rédaction d'un tutoriel pour éviter que les utilisateurs du forum galèrent comme je l'ai fait.

 

Salutation et bon week-end

 

Toucher

Share this post


Link to post
Share on other sites
  • 0

Bonjour Toucher,

Tu disais : "La semaine prochaine je vais entreprendre la rédaction d'un tutoriel pour éviter que les utilisateurs du forum galèrent comme je l'ai fait."

En fait je galère complètement pour partager médiathèque kodi sur mon NAS QNAP TS-853A avec d'autre dispositifs kodi à mon domicile.

Finalement, avais-tu rédigé un tutoriel sur le sujet ? et surtout où puis-je le trouver ?

Merci par avance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By cc66
      Depuis ce matin , il n'y a plus de base de données Mysql : même avec phpmyadmin j'ai ce message :
      " #2002 - No such file or directory &mdash; Le serveur ne répond pas (ou l'interface de connexion vers le serveur MySQL local n'est pas correctement configurée). "
      comment reconnecter la BDD? (si elle est toujours là!
    • By borox
      Bonjour,
      Mon matériel est le suivant:
      Modèle: TS-219P+   Version courante du microprogramme : 4.3.3.0154   J'utilise sur mon NAS mysql et le serveur web ( qui tous les 2 sont activés). J'ai phpmyadmin et 2 applications web installées.
      L'accès à ces 2 sites internet fonctionnent sans problème depuis plusieurs années.
      J'ai remarqué suites aux dernières installation de firmware ( les 2 ou 3 dernières version que j'ai installé) que les sites ne fonctionnent plus ( page blanche). Le serveur web fonctionne ( test d'affichage d'une page en php).
      PHPmyadmin ne fonctionne plus non plus ( page blanche).
      J'ai remarqué ça après une mise à jour de firmware, j'ai retrouvé l'accès après un nouveau firmware mis à disposition et j'ai perdu de nouveau l'accès après une mise à jour à firmware (je n'ai fais aucune aucune autre modification sur le NAS).
      Quelqu'un a une idée sur ce que je pourrai tester pour avancer?
      Merci.
      Nicolas
       
       
    • By Uthagey
      QNAP 269L
      Plus d'accès via Qfinder  depuis le changement de la ram originelle de 1GO contre une autre plus élevée (2go) pour le monter à 4
      (fonctionnait très bien auparavant en mode 1Go originelle + 2Go augmentée)
      Le nas démarre avec son ventilo qui ne s'arrête plus
      J'ai essayé de ré-installer la ram originelle de 1go - même résultat
      > barrette abimée ? > ou autre problème système ?

      Vraisemblablement le Nas ne reboote plus
      Après avis auprès de revendeurs une remise en service n'est pas possible sans la facture d'achat et serait sans doute très cher relativement au prix d'occasion
       
      Quelqu'un-e peut-il ou peut-elle me donner un avis sur la possibilité de remettre le Nas en route ?
      Je m'apprête à le mettre en vente pour pièces. Dernière tentative ici pour le sauver .

       


    • By Misoss
      Bonjour,
      J'ai réinitialisé le mot de passe SQL, cependant j'ai maintenant une erreur de connexion   #1045 Connexion au serveur MySQL non permise.
      Selon la FAQ :
      Q : I changed my password using phpMyAdmin and now I get an error message "Unable to connect to the database: Could not connect to MySQL", how to fix?
      A : This happens because the password is also stored in the Joomla\configuration.php file. Update this file with the new password and everything will work again
      Je ne vois pas ou je peux trouver : "Joomla\configuration.php", et de plus je ne comprends pas ce que Joomla et phpMyAdmin ont en rapport ?
      Merci de votre aide.
    • By cc66
      Bonjour,
      Petite question (de débutant certainement ):
      J'ai installé Limesurvey, une application de sondage en PHP MySQL sur /Web: tout fonctionnait très bien sur la base MySQL configuré au poil.
      Mais je me suis aperçu qu'il y avait un Package QPKG  pour cette appli, et donc pour faire propre, j'ai installé le package (de version plus ancienne mais que j'ai upgradé) tout fonctionnait très bien aussi... sauf que .... l'appli ne travaillait pas avec MA BASE MySQL !...celle de d'habitude où y a toutes mes tables!
      Il semble qu"il y a une autre base Mysql dans ma machine ! Quid?!?
      Donc mes questions : où est elle ? comment la lire avec phpmyadmin et comment rediriger mon limesurvey vers la bonne base (la mienne). et accessoirement comment effacer cette deuxième base inutile (peut être pas si inutile?)
      Désolé si le sujet à été abordé ou si ma question est un peu bébête mais j'ai rien trouvé sur ça en cherchant. (en Linux je suis Minux et puis des occurrences avec MySQL... y en a tellement ....)
       
×