Jump to content
  • 0
Philou44

Depuis La Maj : Impossible De Monter Mon Dossier Nfs...

Question

Bonjour à tous,

 

Avant la MAJ 4.0.2 j'utilisais un montage automatique du répertoire multimedia du NAS afin de synchroniser mon DD externe avec ce répertoire (j'utilise Luckybackup).

Depuis cette MAJ le montage ne s'effectue plus au démarrage (ni après d'ailleurs...) Dans Dolphin j'ai le message suivant quand je clique sur le le répertoire :

 

An error occurred while accessing 'Dossier personnel', the system responded: mount: seul le superutilisateur peut monter 192.168.1.10:/Multimedia sur /media/NAS

 

J'ai un QNAP 559 PRO+ avec le firmware 4.0.2

Je me connecte avec une machine sous OpenSuse 12.3 avec KDE 4.10 mais je n'ai rien changé de ce coté.

 

 

J'ai un peu cherché sur le net ... Mais rien ne semble correspondre réellement à mon problème...

 

Quelqu'un aurait il une idée ?

 

Merci d'avance

 

Philippe

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Bonjour,

 

A priori un problème de droits ... ... malheureusement, cela peut venir d'un droit sur le QNAP (refus d’accès) que d'une erreur locale demandant à ce que root soit le seul à monter le partage ... d'ailleurs est-ce que le montage fonctionne quand vous êtes root (sudo dolphin (ou chemin complet) par ex.)

 

Qu'avez-vous dans les "Accès hôte NFS" sur Multimedia ?

 

Philippe.

Share this post


Link to post
Share on other sites
  • 0

Bonsoir,

 

Merci de vous intéresser à mon problème toujours pregnant.

 

- Même réponse de Dolphin en root

- en console j'obtient : mount: can't find 192.168.1.10/Multimedia in /etc/fstab
 

Dans "Accès hôte NFS" j'ai :

- Droit d'accès : Aucune limite

- Adresse IP ou nom de domaine autorisé :

     *

     192.168.1.0/100 (et mes deux ordi sont dans la plage)

 

Quand je regarde "permission et groupes" j'ai

l'utilisateur ppes (qui correspond à mon ordi ) en R/W

en lecture seule j'ai everyone et un autre utilisateur...

 

ça aide ?

 

Cordialement

 

Philippe

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

 

A ce jour toujours pas de solution à ce problème bien handicapant ...

Quelqu'un aurait il une idée ?

Amicalement

Philippe

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

 

Mettez une question au support (via le site de QNAP ... )

 

Regardez aussi  ici ... il y a plusieurs conseil pour solutionner les montages NFS récalcitrant ...

http://forum.qnap.com/viewforum.php?f=35

 

Je ne peux faire de test avant une dizaine de jour ... 

 

Philippe.

Share this post


Link to post
Share on other sites
  • 0

Tiens tiens. J'ai rencontré le même genre d'erreur aujourd'hui juste après avoir fait la MàJ du firmware.

Il s'avère que j'ai dû modifier mon /etc/fstab pour ajouter l'option "user" (permettant à n'importe quel utilisateur de faire le montage).

De plus, je n'en mettrais pas ma main à couper, mais je suis quasi-sûr que la réponse de showmount -e l-ip-de-mon-nas ne répond plus la même chose. Par exemple, j'ai maintenant /Download. Précédemment, je pense que j'avais /share/Download. J'ai donc changé ça aussi dans mon /etc/fstab (je veux dire : j'ai supprimé le /share)

De mon côté, ça a suffi à rétablir mes montages au démarrage.

 

Espérant que ces pistes vous seront utiles.

 

Julius, heureux d'avoir trouvé un autre utilisateur de la belle combinaison Opensuse 12.3 /KDE + Nas QNAP

Share this post


Link to post
Share on other sites
  • 0

Bonjour Julius,

 

Moi aussi, enchanté de savoir qu'il y a des gens qui tournent sous Linux dont OpenSuse.

--

A propos de mon problème je suis toujours bien bloqué... A propos du FSTAB voici une copie des deux dernière lignes :

192.168.1.10:/nfs    /media/NAS    nfs    defaults 0 0
192.168.1.12:/nfs    /media/WD-NAS    nfs    defaults 0 0

L'IP se terminant par 10 c'est le QNAP qui fait la tête, l'autre (la 12) c'est un WD disque réseau qui lui ne me pose aucun problème...

Avant il y a avait 192.168.1.10:/Multimedia mais ça marchait pas mieux ... C'est moi qui ai modifié le FSTAB comme ci-dessus. (sans succès)

 

Je n'ai pas compris où il aurait fallu que j'ajoute USERS dans ce fstab...

--

---

Sinon la commande showmount me montre correctement l'ensemble des mes directories :

Ils sont tous là...

 

Une idée ?

 

Merci en tout cas

 

Philippe

Share this post


Link to post
Share on other sites
  • 0

Je n'ai pas compris où il aurait fallu que j'ajoute USERS dans ce fstab...

 

"user, auto" à la place de "defaults"

 

C'est ce que j'ai maintenant, et qui fonctionne. Je croise les doigts...

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

 

Avez-vous toujours ce problème (Philippe) ?

 

Je viens de "monter" une Suse 12.3 ... et n'ai pas rencontré de problèmes ...

 

Qu'avez vous dans "Permissions 'accès hôte NFS' "

NO_ROOT_SQUASH ... autre ROOT_SQUASH, ALL_SQUASH, avec nom d'utilisateur ?

 

Je voudrai me mettre le plus proche de votre configuration ... même si je suis sur une Beta QTS 4 ...

 

Philippe.

Share this post


Link to post
Share on other sites
  • 0

Bonsoir Philippe,

 

Merci de vous intéresser toujours à mon problème qui est toujours pregnant effectivement...

- J'ai essayé les manips de Julius dans le fstab mais ça ne fonctionne pas.

 

Heu... C'est où que je trouve les termes NO_ROOT_SQUASH ??

Pour ce qui est de "permission accès hote NFS" je me suis déplacé dans le panneau de contrôle du NAS et j'ai un panneau "modifier les permissions" sous "Dossiers Partagés" c'est là ?

J'ai effectué" des copies d'écran mais je n'ai aucune idée de comment on met des images ici...

 

Philippe (Pas au mieux de sa forme ce soir... :wacko:

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

 

1 Il faut être lorsque vous répondez utilisez "plus d'options de réponse" en bas à droite , vous trouverez "joindre des fichiers" en bas à gauche une fois le fichier choisi et joint, il apparaît au dessus, sur sa ligne apparaît : Ajouter dans le message ou supprimer ... là ajoutez ... une ligne apparaît là ou était le curseur (donc pensez à bien positionner celui-ci) avec attachement ... déplacez là (copier / coller) si elle n'est pas au bon endroit ...

ex. 

post-4-0-73565400-1383380515.gif

 

2 dans "dossier partagés" sur la ligne de votre partage utilisez la 2em petite icone à droite "permission d’accès" dans la liste déroulante "sélectionnez votre type de permission" prendre "Accès hôte NFS", là VOUS Y ÊTES ...

 

Philippe.

NB c'est dans la doc. en ligne  :icon_lol: et meilleure forme ... pour ce week-end ...

Share this post


Link to post
Share on other sites
  • 0

Bonjour Philippe,

Ben alors, c'est ce que j'avais fait mais ça ne fonctionne toujours pas...

Donc mes copies d'écran c'est :

post-2305-0-44394600-1383400913_thumb.pn

et encore

post-2305-0-78829000-1383400922_thumb.pn

Depuis j'ai enlevé les IP 1/100 et laissé juste le "*"

Fait appliqué après

Mais toujours inopérant...

Même réponse dans Dolphin : 

An error occurred while accessing 'Dossier personnel', the system responded: mount: seul le superutilisateur peut monter 192.168.1.10:/Multimedia sur /media/NAS

Je ne comprends pas car j'avais lu la doc (mais je suis pas informaticien et y a pas mal de subtilités qui ne m'éffleurent même pas...

 

A vous lire..

 

Philippe (Moins fatigué qu'hier...)

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

 

L'erreur indique (toujours) qu'il faut être "root" pour demander le montage du point d’accès distant ... (ça c'est vrai !!)

est-ce que votre utilisateur (sur le Linux client) a bien le droit de se substituer (sudo) à root pour ce type de demande ??

 

Il manque un choix sur le menu des propriétés NFS ... mais je suis un peu en avance (  :roll:  désolé, je teste chaque bêta ... je n'ai peur de rien, et j'ai des backups :icon_lol: ) peut-être n'était il pas encore là en 4.0.2 , donc ce ne sera pas de sa "faute" ... si quelqu'un veut bien me le confirmer ??

post-4-0-09316000-1383407402_thumb.png

 

Je ne vois pas trop quoi faire ... je vais essayer, demain, de reproduire cela sur mon PC Linux OpenSuse 12.3 ... avec un utilisateur à droits réduits ...

reste la question à 2 sous ... votre utilisateur, si c'est le même sur le client et le QNAP et admin ont bien le droit de lire / écrire sur Multimédia ???

 

Appelez le support et ouvrez une session teamviewer sur le PC Linux "en cause" ...

 

Philippe.

Share this post


Link to post
Share on other sites
  • 0

Bonjour Philippe,

 

Je vais m'absenter pendant une quinzaine de jours sans accès direct au NAS.

Je reprendrais cette "étude" en revenant.

 

Merci pour votre aide en tout cas

 

A dans 15 jours

Philippe

Share this post


Link to post
Share on other sites
  • 0

Bonjour à toutes et tous,

 

Revenu et j'ai pu re-tester la problèmatique de l'accès.

Il se trouve qu'en bricolant en FTP (à partir de mon gestionnaire de dossier de Linux) les droits des dossiers et fichiers sur le NAS ben... ça re-fonctionne...

Je n'ai pas compris exactement ce que j'ai bien pu faire mais maintenant j'ai de nouveau accès en lecture / écriture à partir de mon logiciel de synchronisation.

 

Suis à la fois content et un peu frustré car je n'ai pas à proprement parlé résolu le problème (lire : Je suis une truffe car je n'ai rien compris de ce qui s'est passé...)

 

Bon l'essentiel c'est que ça fonctionne

 

merci à tous et particulièrement à Philippe qui est toujours là quand on a besoin !

 

A bientôt,

 

Philippe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Guest
      By Guest
      Bonjour,
      Jeune Qnapeur avec un TS-653 Pro depuis 2 semaines, je fait appel a vos connaissances/expériences pour m'aider a régler un problème de droits uniquement avec NFS. En effet, aucun problème a signaler avec FTP ou SMB...
      Quelques infos sur la configuration et l'environnement :
      - NAS Qnap TS-653 Pro
      - PC Multiboot Ubuntu 14.04 LTS et Windows 10 Pro x64.
      - Les UID du PC Ubuntu ont étés modifiées pour correspondre a celles du NAS
      - Même si ca n'est théoriquement pas nécessaire avec NFS, les noms d'utilisateurs et mots de passe sont les mêmes entre le NAS et mes 2 OS (Ubuntu et Windows 10)
      - Le problème rencontré avec NFS ne concerne que NFS. Je n'ai pas ce problème en FTP ni SMB.
      - Dans la maigre configuration que propose le NAS concernant NFS, l'IP (fixe) du PC est indiquée afin de ne permettre qu'a cette machine d’accéder aux partages du NAS (pour NFS bien sur).
      - Les "autorisations avancées sur les dossiers" est activé (je le signale au cas ou ca aurait une importance que j'ignore...). Cependant il n'y a aucune autorisations spéciales sur le dossier homes.
      Le cœur du problème :
      Au démarrage d'Ubuntu, tout va bien. Les 4-5 dossiers sont biens montés et accessibles. Cependant, le dossier /homes ou apparaissent les utilisateurs "admin", "user1" et "user2" sont accessibles en lecture/écriture quelque soit la session ouverte sur Ubuntu... User1 peut donc accéder au home du user2 et lire/écrire dedans. Sur mon ancien NAS Netgear ReadyNAS DUOv2, le dossier home faisait atterrir directement dans le dossier du user concerné /homes/user1/ par exemple. Que les users voient les différents dossiers dans /homes ne me gène pas par contre ce qui me gène beaucoup plus c'est que finalement tout le monde peut aller chez tout le monde faire ce qui lui plait...
      Sous Windows 10, avec SMB, l'accès au dossier home ne liste pas les dossiers utilisateurs du NAS mais fait bien atterrir l'utilisateur dans son propre dossier sur le NAS.
      J'ai essayer les quelques options (malheureusement très peu nombreuses) que propose le NAS mais rien n'y fait. Les UID/GID anonymes sont ceux par défauts a savoir "Guest" et en essayant de modifier les 4 options root_squash/no_root_squash/all_squash et no_all_squash... c'est pareil. Dans le meilleurs des cas, j'ai réussi a empêcher un user a accéder a son propre home mais par contre il ne pouvait plus non plus écrire dans celui des autres...
      Je dois avouer que les options squash ne sont pas très claires pour moi malgré différents sites parcourus sur le sujet. Rediriger le root local vers anonyme du serveur ou je ne sais quoi... j'suis un peu perdu. Dois-je justement modifier ceux par défaut qui sont "guest" dans le NAS ?
      En vous remerciant d'avance pour m'avoir lu jusqu'au bout...
    • By father_mande
      Bonjour,

      Qfinder for Linux

      testé aussi sous Debian : http://forum.qnap.com/viewtopic.php?f=57&t=60191



      ATTENTION X86 seulement ... bien sur c'est pour un PC client

      Philippe.
×