Jump to content
  • 0
makos

FTP TLS/SSL de l'extérieur : Solution

Question

Bonjour à tous...

j'ai galéré avant de de rendre efficiente ma connexion FTP TLS/SSL depuis l'extérieur. Cela marchait en LAN mais pas en WAN.

J'ai fini par trouver une solution, je vous la livre :

- Dans les paramètres FTP du NAS, cocher le partage FTP TLS/SSL, puis changer la plage de ports passifs = 50000 à 50100

- Cocher l'option "Répondre par une adresse extérieur..." et indiquant dans le champ disponible votre adresse WAN (celle du fournisseur d'accès)

- Côté routeur : Nat des port 20,21 et 50000 à 501000 vers l'adresse LAN de votre NAS (IP fixe recommandée pour votre NAS)

... ça marche :-)

Edit : La connexion du client FTP derrière un firewall sur ce type de serveur FTP sécurisé est quasi-impossible... à savoir.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Le firewall ne dérange pas, il suffit de le paramétrer pour autoriser les ports ouvert dans le routeur pour l'adresse IP local du serveur.

ensuite ca roule sans soucis.

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Dans mon cas :

Dans Filezilla, unique réglage :

- FTP sur TLS/SSL chiffrement explicite

Dans Qnap :

- j'ai coché FTP with SSL/ TLS (explicit)

J'ai laissé la plage par défaut et rien touché au reste. C'est le port 21

- dans routeur (avec firewall) derrière livebox

Renvoi du port 21 et de la plage par défaut sur le Qnap.

c'est tout. Bonne journée

Share this post


Link to post
Share on other sites
  • 0

Merci Makos !

En effet il faut ouvrir les ports que l'on précise (par défaut 50000 - 51000) pour que sa fonctionne de l'exterieur en FTP SSL.

Moi aussi je commencais à m'arracher les cheuveux :)

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

J'ai suivi votre mode opératoire et cela ne fonctionne pas en extérieur dans mon cas.

J'ai le message : "Impossible d'établir une connexion au serveur"

Par contre sur le reseau interne j'ai aucun souci.

J'ai un QNAP TS-809 Pro, j'ai activer le service FTP et cocher FTP avec SSL/TLS puis configurer les ports FTP passifs en manuel.

J'ai ouvert ces ports sur mon routeur DG834N.

Le nas a un nom dyndns pour pouvoir se connecter via ftp dessus.

J'ai essayé en ftp normal cela fonctionne qd je passe en FTP TLS explicite c'est ko.

Je suis toujours au même point.

Si quelqu'un a une idée je suis preneur.

Merci d'avance pour votre aide.

Cordialement.

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Je viens de lire le sujet et fais scrupuleusement tout ce que vous avez dit, mais mon problème persiste.

Je possède un NAS QNAP TS-469L et depuis que je l'ai il impossible de communiquer avec le NAS depuis l'extérieur de mon domicile lorsque j'active le FTP avec SSL/TLS (explicite).

Afin de sécuriser les communications avec mon NAS depuis internet, je veux à tout pris utiliser le FTP SSL/TLS. Pour se faire, j'ai activé cette option dans l'onglet FTP, numéro de port 21 (marche pas) puis 990 (marche pas aussi), plage de port défini entre 50000 et 50100, "réponse par une adresse IP externe à la requête d'une connexion FTP passive" avec mon adresse publique 82.XXX.X.XXX. Côté routeur (freebox mini 4K), j'ai redirigé les ports suivants sur l'adresse privée de mon nas 192.XXX.X.XX, en UDP et TCP : 8080, 21, 22, 20, 443, 50000, 50100, 990, 989 et 80.
Côté DNS, j'utilise noip et pour le certificat j'utilise "QTS SSL Certificate" qui apparemment ne sécurisé que la connexion à l'espace d'administration du NAS via l'explorateur internet

Malgré tout ça et après des semaines de galères, il m'est impossible d'accéder à mon NAS depuis internet lorsque j'active l'option FTP SSL/TSL.

  • En LAN lorsque dans l'explorateur windows je tape l'adresse "ftp://82.XXX.X.XXX" ou  "ftps://82.XXX.X.XXX" le message d'erreur apparaît : "Erreur du dossier FTP : Windows ne peut accéder à ce dossier. Vérifier que le nom du fichier indiqué est correct et que vous avez l'autorisation d'accéder à ce dossier. Détails : Impossible d'établir une connexion avec le serveur" Idem lorsque je tente avec Filezilla Client.
  • En WAN, même message


Voilà, j'ai beau retourner le problème dans tous les sens, je n'arrive pas à trouver la solution. Du coup j'ai un NAS vierge que je ne veux pas utiliser tant que le protocole FTP SSL/TLS n'est pas en place afin d'éviter que quiconque puisse accéder à mes données en clair.

J'espère que vous pourrez m'éclairer.

Cdlt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×