Aller au contenu
nas60

MariaDB et PHPmyAdmin

Messages recommandés

nas60    0

Bonjour,

Je suis un nouvel utilisateur de Qnap.

En janvier dernier, j'avais activé un premier nas TS251 sur lequel je devais faire tourner une base de données mysql. J'avais eu la nécessité de modifier un paramètre dans la base "information_schema" puis dans la table "GLOBAL_VARIABLES" et en fin passer de 0 à 1 le champ "Lower_CASE_TABLE_NAMES" or impossible de le faire depuis phpmyadmin et impossible de le faire depuis l'extérieur avec Navicat par exemple.

Après de nombreux essais j'ai  réussi en utilisant winscp.exe pour aller chercher le fichier my.cnf et y ajouter la ligne Lower_CASE_TABLE_NAMES =1.

Aujourd'hui, je suis en cours d'installation d'un deuxième nas, le TS-453A. J'ai exactement le même problème or mon winscp.exe ne trouve aucun fichier my.cnf tout comme il n'affiche pas le répertoire phpmyadmin alors que celui-ci est visible depuis le file explorer du nas.

En sus, je ne comprends pas pourquoi le fichier my.cnf du premier nas est également introuvable.

Merci d'avance

Partager ce message


Lien à poster
Partager sur d’autres sites
FredP    12

Bonjour,

Que répond la commande : find / -name "my.cnf" ?

C'est relativement bavard chez moi...

Cordialement

Partager ce message


Lien à poster
Partager sur d’autres sites
nas60    0

Bonjour.

Merci de votre réponse.

En fait, nous avons l'utilitaire File Station, et c'est le seul qui nous sert pour pouvoir accéder aux contenus du disque. Or, peut être par raison de sécurité, on ne peut y voir que nos données personnelles ainsi que le dossier de PhpMyAdmin.

Voilà, si vous savez par quel moyen on peut voir par exemple le dossier d'installation du serveur MariaDB, çà nous aiderait.

Merci d'avance. Cordialement.

Partager ce message


Lien à poster
Partager sur d’autres sites
FredP    12

Bonjour,

Effectivement, vous n'irez pas loin avec ça. C'est au coeur du système qu'il faut chercher!

Il suffit d'activer le service SSH (Service réseau, telnet/SSH) dans la console d'administration pour saisir la commande que je vous ai proposé et d'ouvrir une session avec un outil idoine: Putty/mRemoteNG par exemple sur Windows, l'outil intégré de terminal des OS Unix/linux/OSX ou un autre que vous trouverez facilement sur le Web...

Vous pouvez aussi utiliser en complément et pour l'aspect graphique le serveur ftp/sftp avec le compte admin en l'activant dans la console d'administration et utiliser ensuite un client ftp classique.

Pour la recherche de fichiers et une modification rapide, la ligne de commande est pratique... Pour la découverte et l'édition longue, le client ftp (personnellement j'utilise filezilla..) peut s'avérer utile. Vous avez là mes armes de guerre :-)

Cordialement.

Partager ce message


Lien à poster
Partager sur d’autres sites
nas60    0

Oui, on a aussi pensé à telnet, et essayé avec telnet de win10 avec commande de connexion "o adresse_IP port_telnet_surNAS" mais connexion impossible.

Pour ce qui est du FTP, déjà essayé aussi, mais ce sont les mêmes dossiers perso qu'on trouve.

On va essayer Putty et on verra.

Merci. A plus

Partager ce message


Lien à poster
Partager sur d’autres sites
FredP    12

Bonjour,

Il faut bien sûr activer les services sur le NAS et se connecter avec le compte admin (équivalent root..) pas le vôtre.

Cordialement.

Partager ce message


Lien à poster
Partager sur d’autres sites
nas60    0

OK, test de connexion via mRemoteNG avec les différents protocoles, dont SSH, Telnet, HTTP; mais seul HTTP a fonctionné et on a le même interface web du QNAP. Login admin et son mot de passe utilisé.

"En limant, on fait d'une poutre une aiguille", donc on persévère, mais il ne faut pas trop "chercher une aiguille dans une botte de foin", hihihi

Partager ce message


Lien à poster
Partager sur d’autres sites
FredP    12

Bonjour,

La commande pour chercher le fichier my.cnf a été assez bavarde mais elle a réellement pointé vers quelques fichiers:

/etc/default/my.cnf: C'est à priori le fichier auquel il ne faut pas toucher, celui qui est restauré dans le cas ou on lance une remise à zéro.

/etc/my.cnf: ce n'est qu'un lien symbolique vers le fichier /mnt/HDA_ROOT/.config/my.cnf qui est le fichier que vous modifiez, enregistrez et qui est stocké entre chaque redémarrage.

Ces deux-là, je suis à peu près certain qu'ils se retrouvent partout. Attention, le dossier ".config" nécessite l'affichage de dossiers cachés par les clients ftp ou autres!

/mnt/ext/opt/mariadb/my.cnf: Un petit dernier... dont j'ignore l'utilité mais à explorer.

Voilà de quoi déjà vous y retrouver un peu en principe.

Cordialement.

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites
nas60    0

Comme disait une Cheffe : "A force de péclacher, on évite de tourner en rond". Accès par SFTP réussi.

On a utilisé NetDrive et comme options "Connect to system root folder", tous les dossiers principaux sont visibles.

Reste maintenant à trouver my.cnf

Toutefois, grand merci à toutes vos réponses, çà nous a bien aidé.

Cordialement.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


  • Contenu similaire

    • Par borox
      Bonjour,
      Mon matériel est le suivant:
      Modèle: TS-219P+   Version courante du microprogramme : 4.3.3.0154   J'utilise sur mon NAS mysql et le serveur web ( qui tous les 2 sont activés). J'ai phpmyadmin et 2 applications web installées.
      L'accès à ces 2 sites internet fonctionnent sans problème depuis plusieurs années.
      J'ai remarqué suites aux dernières installation de firmware ( les 2 ou 3 dernières version que j'ai installé) que les sites ne fonctionnent plus ( page blanche). Le serveur web fonctionne ( test d'affichage d'une page en php).
      PHPmyadmin ne fonctionne plus non plus ( page blanche).
      J'ai remarqué ça après une mise à jour de firmware, j'ai retrouvé l'accès après un nouveau firmware mis à disposition et j'ai perdu de nouveau l'accès après une mise à jour à firmware (je n'ai fais aucune aucune autre modification sur le NAS).
      Quelqu'un a une idée sur ce que je pourrai tester pour avancer?
      Merci.
      Nicolas
       
       
    • Par Misoss
      Bonjour,
      J'ai réinitialisé le mot de passe SQL, cependant j'ai maintenant une erreur de connexion   #1045 Connexion au serveur MySQL non permise.
      Selon la FAQ :
      Q : I changed my password using phpMyAdmin and now I get an error message "Unable to connect to the database: Could not connect to MySQL", how to fix?
      A : This happens because the password is also stored in the Joomla\configuration.php file. Update this file with the new password and everything will work again
      Je ne vois pas ou je peux trouver : "Joomla\configuration.php", et de plus je ne comprends pas ce que Joomla et phpMyAdmin ont en rapport ?
      Merci de votre aide.
    • Par gogol
      Bonjour,
      J'ai installé mon TS-453A puis activé serveurs SQL - MariaDb, activé le port 3306 et enfin installé phpMyAdmin.
      Je l'ai déjà fait par le passé sur d'autres Qnap et je n'avais rencontré aucun problème et là non plus.
      J'ouvre le phpMyAdmin avec "root" et "admin" pouis je vais en haut sous "paramètres généraux" et "modifier le mot de passe", je rentre autre chose et fait exécuté.
      Lorsque je quitte et je reviens j'ai ce fameux message
      #1045 - Access denied for user 'root'@'localhost' (using password: YES)
      et je ne peux ni utiliser l'ancien ni le nouveau mot de passe et ce même si je redémarre le qnap
      Je ne peux que réinitialiser le mot de passe depuis sql mais l'objectif n'est pas d'avoir le mot de passe d'origine.
      Merci à celui qui peut m'orienter
    • Par QoolBox

      Source : http://www.phpmyadmin.net/home_page/index.php
      Download :
      http://www.positiv-it.fr/QNAP/APP/QPHPMyAdmin_4.3.10.qpkg.zip (4.1.x)
      http://www.positiv-it.fr/QNAP/APP/QPHPMyAdmin_4.5.0.2.qpkg.zip (4.2.x)
      http://www.positiv-it.fr/QNAP/APP/QPHPMyAdmin_4.5.1.0.qpkg.zip (4.2.x)
      http://www.positiv-it.fr/QNAP/APP/QPHPMyAdmin_4.5.1.0_x19_x12_x21.qpkg.zip (4.2x armv5 version)
      Note :
      pour vous logger,, entrez un utilisateur et son mot de passe correspondant à un utilisateur du Serveur MySQL (user root /pass admin)
      actuellement ne fonctionne pas avec la version officiel du serveur MySQL QNAP
    • Par YLYKAS
      Bonjour à tous,
       
      Après avoir supprimé Wordpress de mon serveur, en me connectant via phpMyAdmin j'ai vu qu'il y'avait plein de comptes utilisateurs, pensant que c'était des reste de Wordpress, j'ai tout coché et tout supprimé depuis je n'arrive plus à me connecter via le compte root.
      J'ai bien sûr cliqué sur "Réinitialiser le mot de passe root" et sur "Initialiser la base de données" dans le panneau de contrôle de mon QNAP, sans succès.
      Si je vais sur /phpmyadmin avec mon navigateur et que j'essaye de me connecter avec root/admin j'ai le droit à un #1045 Connexion au serveur MySQL non permise
      J'ai donc cherché pendant plusieurs heures sur des forums.. J'ai essayé de me connecter via SSH :
      [/mnt/ext/opt/mysql/bin] # ./mysql -u root ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) [/mnt/ext/opt/mysql/bin] # donc ça ne fonctionne pas non plus..    Bref pour résumer : si quelqu'un pourrait me dire comment recréer un compte root dans MySQL via SSH ça serai vraiment sympa.   Si je trouve aucune solution je formaterai mon QNAP mais j'aimerai vraiment éviter d'en arriver là vu que j'ai 4To de dossier dessus..   Merci d'avance    
       
       
×