Jump to content

Recommended Posts


A new version is now available on the repository
Version: 14.0.2

Share this post


Link to post
Share on other sites

UPDATE: answered my own question. Updater worked (at least as far as I can tell.)

New question, where are my files stored with this install? With my original install, I could access my files on my networked pc's at \\QNAPNAS\Web\nextcloud\data\admin and via the web at http://[myqnapip]/nextcloud but once I reinstalled this latest NC14 from scratch  (presumably the right way) I access Nextcloud on the web via http://[myqnapip]:45080/ but not sure where or if I can access directly on my network. Assuming I can't and would have to use ftp or ssh but thought I'd check with people who know more than I do.

Are we able to update using the updater? If not, what is the process to update?  

Edited by Justs
change in question

Share this post


Link to post
Share on other sites

Salut,

Merci pour cette nouvelle mise à jour. 
Comme après chaque MAJ il faut penser à modifier le fichier /share/CACHEDEV1_DATA/.qpkg/NextCloud/httpd-ssl.conf
J'en ai également profité pour mettre a jour QApache : la conf PHP n'est plus au même endroit, ça m'a posé problème pour Nextcloud. Le fichier se trouve mantenant dans /share/CACHEDEV1_DATA/.qpkg/Qapache/etc/conf/php.ini

Dans Nextcloud, la fonction "Avertissements de sécurité & configuration" me signale quand même plusieurs problèmes que je n'ai pas réussi a corriger :

  •     L'utilisation de la fonctionnalité d'envoi d'e-mails native de PHP n'est plus supportée. ----> problème résolu en configurant le mode d'envoi "sendmail"
  •     Index "fs_mtime" manquant dans la table "oc_filecache". ----> problème résolu en exécutant en la requete SQL ALTER TABLE `oc_filecache` ADD KEY `fs_mtime` (`mtime`) USING BTREE;
  •     L'en-tête HTTP "Referrer-Policy" n'est pas défini sur "no-referrer".
  •     Des fichiers n'ont pas passé la vérification d’intégrité :

    Technical information
    =====================
    The following list covers which files have failed the integrity check. Please read
    the previous linked documentation to learn more about the errors and how to fix
    them.

    Results
    =======
    - core
        - EXTRA_FILE
            - 3rdparty/rackspace/php-opencloud/docs/changelog/Upgrading to 1.7.0.md

 

 

Si quelqu'un sait comment résoudre ces soucis, je suis preneur !
Merci d'avance

PS : le forum en HTTP only c'est vraiment pas top ... En espérant que c'est temporaire !

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 14.0.3

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 14.0.3

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 14.0.4

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.0

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.0

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.0

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.2

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.2

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.2

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.4

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.4

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.4

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.5

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.5

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.5

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 15.0.7

Share this post


Link to post
Share on other sites

A new version is now available on the repository
Version: 16.0.0.0

Share this post


Link to post
Share on other sites

Upgrade from 15.0.7 to 16.0.0 fails.

Tested GUI & CLI. CLI details below

# /share/CACHEDEV1_DATA/.qpkg/Qapache/bin/php -f /share/CACHEDEV1_DATA/.qpkg/NextCloud/nextcloud/occ upgrade
~
The current PHP memory limit is below the recommended value of 512MB.
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Set log level to debug
Doctrine\DBAL\Exception\DriverException: An exception occurred while executing 'DROP TABLE oc_news_items':

SQLSTATE[HY000]: General error: 13 database or disk is full
Update failed
Maintenance mode is kept active
Reset log level

 

Share this post


Link to post
Share on other sites

"cron jobs not running"

qnap 4.3.6.0907
nextcloud NextCloud_15.0.7_x86_64.qpkg / NextCloud_16.0.0_x86_64.qpkg
qapache 2439.7217

Tested both PHPs in crontab, but none of them initiates the cron updates (required for "News" to refresh feeds)
https://apps.nextcloud.com/apps/news
https://docs.nextcloud.com/server/16/admin_manual/configuration_server/background_jobs_configuration.html#cron

When I run

[server]# /mnt/ext/opt/apache/bin/php -f /share/CACHEDEV1_DATA/.qpkg/NextCloud/nextcloud/cron.php


manually, the cron.php refreshes (with lib errors thou). But when the same config is in crontab it does not work.

Anybody has any suggestions how to fix it please?
Cheers

****************

[server]# /mnt/ext/opt/apache/bin/php -f /share/CACHEDEV1_DATA/.qpkg/NextCloud/nextcloud/cron.php
This version of Nextcloud requires at least PHP 7.1<br/>You are currently running 5.6.38. Please update your PHP version.

[server]# /share/CACHEDEV1_DATA/.qpkg/Qapache/bin/php -f /share/CACHEDEV1_DATA/.qpkg/NextCloud/nextcloud/cron.php
PHP Warning:  PHP Startup: Unable to load dynamic library 'gender.so' (tried: /opt/Qapache/lib/extensions/no-debug-zts-20170718/gender.so (/opt/Qapache/lib/extensions/no-debug-zts-20170718/gender.so: cannot open shared object file: No such file or directory), /opt/Qapache/lib/extensions/no-debug-zts-20170718/gender.so.so (/opt/Qapache/lib/extensions/no-debug-zts-20170718/gender.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'protobuf.so' (tried: /opt/Qapache/lib/extensions/no-debug-zts-20170718/protobuf.so (/opt/Qapache/lib/extensions/no-debug-zts-20170718/protobuf.so: cannot open shared object file: No such file or directory), /opt/Qapache/lib/extensions/no-debug-zts-20170718/protobuf.so.so (/opt/Qapache/lib/extensions/no-debug-zts-20170718/protobuf.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  Module 'rar' already loaded in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'seaslog.so' (tried: /opt/Qapache/lib/extensions/no-debug-zts-20170718/seaslog.so (/opt/Qapache/lib/extensions/no-debug-zts-20170718/seaslog.so: cannot open shared object file: No such file or directory), /opt/Qapache/lib/extensions/no-debug-zts-20170718/seaslog.so.so (/opt/Qapache/lib/extensions/no-debug-zts-20170718/seaslog.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'taint.so' (tried: /opt/Qapache/lib/extensions/no-debug-zts-20170718/taint.so (/opt/Qapache/lib/extensions/no-debug-zts-20170718/taint.so: cannot open shared object file: No such file or directory), /opt/Qapache/lib/extensions/no-debug-zts-20170718/taint.so.so (/opt/Qapache/lib/extensions/no-debug-zts-20170718/taint.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'xmldiff.so' (tried: /opt/Qapache/lib/extensions/no-debug-zts-20170718/xmldiff.so (/opt/Qapache/lib/extensions/no-debug-zts-20170718/xmldiff.so: cannot open shared object file: No such file or directory), /opt/Qapache/lib/extensions/no-debug-zts-20170718/xmldiff.so.so (/opt/Qapache/lib/extensions/no-debug-zts-20170718/xmldiff.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

[server]# crontab -l
# m h dom m dow cmd
~
*/15  *  *  *  /share/CACHEDEV1_DATA/.qpkg/Qapache/bin/php -f /share/CACHEDEV1_DATA/.qpkg/NextCloud/nextcloud/cron.php

[server]# crontab /etc/config/crontab && /etc/init.d/crond.sh restart
Stopping periodic command scheduler: crond.
Starting periodic command scheduler: crond.

Share this post


Link to post
Share on other sites

found the problem with cron :-) ... one missing "*" star 

# crontab -l
# m h dom m dow cmd
~
*/15  *  *  *  *  /share/CACHEDEV1_DATA/.qpkg/Qapache/bin/php -f /share/CACHEDEV1_DATA/.qpkg/NextCloud/nextcloud/cron.php

Share this post


Link to post
Share on other sites

Bonjour , 

debutant dans tout cela . je viens d'installer le QApache et le NEXTCLOUD.QPKG . 

tout fonctionne sur mon lan et depuis internet . mais cependant 2 choses subsistent :

 - j'ai ajouté via le menu des applis l'application collabora . mais quand j'essaie d'ouvrir un fichier odt ou word j'ai le message suivant : Failed to load Collabora Online - please try again later . 

- depuis l'application nextcloud sur android honor 9 ou sur ipad et que je parametre l'upload de mes photos , rien ne se synchronise (meme en forcant la synchro) 

****************************

Hello , 

starting out in all this. I just installed the QApache and NEXTCLOUD.QPKG . 

everything works on my lan and from the internet... but nevertheless 2 things remain:

 - I added via the apps menu the application will collaborate. But when I try to open an odt or word file I get the following message: Failed to load Collabora Online - please try again later . 

- since the nextcloud application on android honor 9 or ipad and I set the upload of my photos, nothing synchronizes (even by forcing synchronization) 

Translated with www.DeepL.com/Translator

 

Merci

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×