Aller au contenu
  • 0
Memphis

[RESOLU] Accès NAS QNAP impossible suite ajout routeur ASUS

Question

Memphis    0

Bonjour,

Je viens vous soumettre un problème d'accès à mon NAS QNAP TS-212P.

Le problème est apparus suite à l'ajout à mon réseau d'un routeur ASUS.

Je possède une box 4K SFR qui depuis quelques semaines ne redirige plus les ports (Problème à priori connus depuis la dernière mise à jour...), c'est ce qui m'a décidé à acheter un routeur ASUS.

J'ai donc passé la box en mode bridge, j'ai modifié les infos réseaux sur le NAS (IP passerelle), puis redémarré tous les appareils.

Or, je ne peux plus accéder à l'interface d'administration que cela soit par HTTP (local) ou par Qfinder.

 

La LED de status sur le NAS est verte.

Le NAS apparaît bien dans Qfinder.

Le NAS apparaît sur le routeur et répond au PING.

J'ai désactivé le firewall du routeur mais rien n'y fait.

 

Auriez-vous une idée pour résoudre ce problème?

Partager ce message


Lien à poster
Partager sur d’autres sites

13 réponses à cette question

Messages recommandés

  • 0
byte_order    6

> Or, je ne peux plus accéder à l'interface d'administration que cela soit par HTTP (local) ou par Qfinder.

 

par local, vous entendez accès en HTTP sur le réseau local ? Qu'affiche votre navigateur : 404, timeout ou un autre contenu web à la place de celui de l'admin web du NAS ?

Votre NAS est branché sur le routeur ASUS si j'ai bien suivi. Bien qu'en théorie un routeur ne fait de la gestion de trafic que sur le trafic franchissant entre le WAN (donc le trafic depuis/vers votre box SFR) et le LAN, pas sur le trafic purement LAN, y'a p'tet un problème de configuration qui fait intercepter les requettes HTTP de votre navigateur avant qu'elles atteignent votre NAS. En particulier sur le port 80, mais normalement l'interface web des NAS est en 8080.

Si vous branché votre cable ethernet directement sur votre NAS, est-ce que cela marche comme attendu ?

Si oui, modifié le port 8080 en autre chose plus improbable pour voir si cela passe alors le routeur.

Les routeurs grand publics récents aiment bien intercepter le trafic local pour gérer l'auto-découverte du routeur qui facilite sa première installation. y'a pet un conflit quelque part.

 

Ah, oui, quel modèle de routeur Asus SVP ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Memphis    0

Oui, je parle de l'accès en local via l'adresse IP statique que j'ai défini dans les paramètres à savoir 192.168.1.60

Le navigateur renvoi " ERR_CONNECTION_TIMED_OUT ".

 

Le NAS ainsi que mon ordinateur sont branchés sur le routeur qui est un ASUS RT-AC68.

L'accès HTTP du routeur est paramétré sur un autre port (1xxx).

 

Quand vous parlez de brancher directement le câble ethernet sur le NAS vous parlez du câble de mon ordinateur?

 

Si le problème vient de la configuration réseau du NAS, est-il possible de faire un reset de ses paramètres sans modifier le reste?

Sinon, comment accéder au NAS? (J'ai bien essayé de le rebrancher sur la box mais le NAS étant en IP fixe différent de la box (192.168.0.1) cela ne va pas...)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
copaya    3

Bonjour,

Il y a 8 heures , Memphis said:

Sinon, comment accéder au NAS? (J'ai bien essayé de le rebrancher sur la box mais le NAS étant en IP fixe différent de la box (192.168.0.1) cela ne va pas...)

soit en attribuant une IP en 192.168.1.X à la Box...........et connecter le NAS sur la Box.........

soit en attribuant une IP en 192.168.1.X au PC............et connecter le Nas au PC.........

Cordialement

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Memphis    0

Bonjour,

Merci pour votre aide.

 

J'ai essayé différentes choses:

Branchement direct PC-NAS, en attribuant au PC l'IP 192.168.1.10: ne fonctionne pas.

Branchement du PC et du NAS sur un mini routeur NEXX configurer en 192.168.1.1: ne fonctionne pas.

 

Pour info, je ne trouve plus mon NAS avec Qfinder et j'ai reçu une notification sur mon application QManager Android ce matin donc le NAS semble OK et j'ai dû louper quelque chose dans la configuration de celui-ci...

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Memphis    0

J'ai décidé de faire un reset simple (3 sec).

Dans un premier cela c'est bien passé puisque j'ai pu à nouveau me connecter à QTS sauf que quand j'ai voulu ouvrir la fenêtre de configuration QTS s'est figé.

Depuis, impossible de me connecter même après un nouveau reset simple...

 

Auriez-vous une idée?

Merci.

 

[EDIT] J'ai trouvé...

Je ne sais pour quelle raison mais l'adresse IP de mon PC a été banni (prévu dans les règles de protection).

Je l'ai changé et c'est bon j'ai accès à mon NAS.

 

Voilà, peut-être ce post servira un jour à quelqu'un.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
byte_order    6

Bonjour,

 

Je vous conseille d'aller voir dans les logs de votre NAS les détails sur les connexions depuis votre PC ayant abouti au bannissement de son adresse IP.

Il est possible qu'un malware soit installé sur votre PC, et que ce soit celui-ci qui ait fait des connexions "douteuses".

Si vous pouvez utiliser une tablette ou un smartphone pour acceder à 'linterface web de votre NAS pour faire cette vérification, cela eviterait de prendre le risque qu'un éventuel malware sur votre PC, le cas échéant, en profite pour reprendre ses activités.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Memphis    0

Bonjour,

 

Effectivement, je ne suis même pas allé voir...

Après examen, je ne trouve aucune trace de connexion "fail" dans les logs.

Je vois bien le moment où l'adresse IP de mon PC a été banni mais pas de connexion manqué avant...

 

Est-ce que quand dans Sécurité > Niveau de sécurité, le choix est sur "Permettre uniquement les connexions depuis la liste", les IPs qui ne sont pas dans la liste sont automatiquement bannis?

 

J'ai dû mal à comprendre là...

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
byte_order    6

> Est-ce que quand dans Sécurité > Niveau de sécurité, le choix est sur "Permettre uniquement les connexions depuis la liste",
> les IPs qui ne sont pas  dans la liste sont automatiquement bannis?

Ah. Oui, cette option signifie que *seuls* ces adresses IP listées sont autorisées à accéder à votre NAS.

Et dans ce cas, la probable explication est que suite à l'installation de votre nouveau routeur Asus, votre PC n'a pas reçu la même adresse IP qu'habituellement et qu'à la première tentative d'accès (ou depuis) à votre NAS, celui-ci rejette votre PC avec une autre adresse IP.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Memphis    0

En fait,je ne sais plus trop comment c'était configuré.

A l'origine, le niveau de sécurité était sur Refuser les connexions depuis la liste où était stockés les IP bannis.

Ayant plusieurs bannissement par jour, j'ai choisi l'option Permettre uniquement les connexions depuis la liste où j'avais paramétré le réseau interne.

 

Et effectivement, le nouveau routeur étant en 192.168.1.1 au lieu de 192.168.0.1 pour la box, c'est pour cela que j'étais bloqué.

Le reset simple a dû modifier ce paramètre.

Mais j'ai quand même l'adresse IP (192.168.1.27) du PC qui a été banni à un moment et pourtant aucune connexion fail dans les logs...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
byte_order    6

cela ne sera pas une connexion "failed" proprement dit dans ce cas, mais une connexion "refusée" explicitement.

La présence de plusieurs bannissement par jour dans l'ancienne configuration semble indiquer que votre NAS était exposé à des tentatives d'attaques depuis Internet. Avoir basculer l'option "uniquement ces adresses IP" vous en protège, mais vous oblige désormais a avoir des adresses IP fixes pour vos équipements devant accéder à votre NAS.

Comme vous êtes revenu à la configuration par défaut, toutes les adresses IP sont à nouveau autorisées.

Et votre routeur n'expose probablement pas par défaut des services de votre NAS sur Internet, ce que semblait faire votre box SFR. Mais par sécurité, je vous invite à :

- activer le bannissement temporaire automatique des adresses IP ayant échoué de se connecter en SSH, FTP, telnel, https, etc.

Panneau de contrôle > Paramètres systèmes  > Sécurité > onglet Protection d'accès au réseau > activer la protection au réseau

- vous assurez d'avoir un mot de passe admin qui ne soit pas hyper facile à trouver en "brute force", car quand bien même le bannissement automatique à la fail2ban stoppera des milliers par jour de tentatives échouées, il suffit d'une tentative réussie pour passer et faire de gros dégât. Un mot de passe hyper répandu et le risque qu'une attaque brute force passe rapidement avant le bannissement automatique grimpe sérieusement...

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Memphis    0

Bonjour,

 

Effectivement, on dirait que le routeur ASUS est plus sécurisé (toutes les options de sécurité sont activées) puisque je n'ai plus de tentative d'accès (pour le moment en tout cas).

J'ai activé le bannissement définitif et tout les services inutiles sont désactivés.

Mon mot de passe n'est pas simple mais je vais le renforcer encore.

 

Merci pour vos conseils.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
byte_order    6

eviter le bannissement définitif en https, car si vous oubliez ou perdez votre mot de passe, après N tentatives c'est foutu faudra forcer un changement d'adresse ip locale pour votre PC pour retenter le coup ;-)

Bannir pendant N minutes / heures après 2-3 tentatives échouées est en général amplement suffisant pour dissuader les attaques en brute-force.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×