Jump to content
  • 0
Sign in to follow this  
cc66

Pas de commande php dans ligne de commande

Question

Pour gérer MediaWiki et ses "scripts de Maintenance", il faut passer directement des lignes de commande du type:

php rebuildall.php 

avec par exemple putty mais il est impossible de lancer la ligne car la commande php n'existe pas !?!

Pourtant j'ai bien php sur mes sites Web mais php n'est pas dans la liste des commandes possible. Comment l'installer?

j'ai un TS-431

 

 

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Bonjour,

Ca ne me parle pas beaucoup mais en jetant un oeil dans le NAS, je ne vois effectivement pas grand chose qui ressemble à un exécutable qui pourrait vous servir.

Par contre, vous pourriez peut-être utiliser Entware et l'un de ses package PHP 5 ou 7 avec cli pour répondre à votre question.

Voyez ici: https://forum.qnap.com/viewtopic.php?f=351&t=124894 Choisissez votre QPKG en fonction du processeur de votre NAS. Explorez aussi les packages en fonction du processeur de votre NAS sur la même page.

Cordialement.

Share this post


Link to post
Share on other sites
  • 0

une réponse un peu tardive (mieux vaut tard que jamais !)

Effectivement le qpkg de mediawiki à été mis a jour et j'ai trouvé la version pour mon qnap et elle fonctionne .

 

merci

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×