Aller au contenu

Question

Bonjour, 

Ayant des problèmes de communication entre mon Raspberry PI et mon Nas Qnap TS410 sur la version 4.2.6 .

Le problème viendrait de la version du SMB qui ne serait pas a jour sur mon Nas. Je me suis donc renseigné et tombé sur ce tuto. très bien expliqué : https://www.qnap.com/en/how-to/tutorial/article/how-to-use-smb-3-0-in-qts-4-2
Hélas je n'ai pas l'option du choix de la version SMB :huh:

Y aurais t'il une possibilité ou ai-je loupé une étape ?

SMB.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

3 réponses à cette question

Messages recommandés

  • 0

Bonjour matinal,

Un poil de recherche ne fait pas de mal, si le firmware est à jour, les ressources aussi sur ce type de firmware et que vous vous mettiez aux terminaux ssh:

 

Bonne journée. J'ose espérer que ça devrait le faire mais ne comptez pas sur les interfaces Web, non non!

Bien cordialement.

FredP

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Si dessous mon log du Raspberry :

May  7 01:17:07 Raspberry: [    9.903439] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
May  7 01:17:07 Raspberry: [    9.903894] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
May  7 01:17:08 Raspberry: [   10.006069] CIFS VFS: Error connecting to socket. Aborting operation.
May  7 01:17:08 Raspberry: [   10.006073] CIFS VFS: Error connecting to socket. Aborting operation.
May  7 01:17:08 Raspberry: [   10.006082] CIFS VFS: cifs_mount failed w/return code = -101
May  7 01:17:08 Raspberry: [   10.006086] CIFS VFS: cifs_mount failed w/return code = -101
May  7 01:17:08 Raspberry: [   10.789381] Adding 1048572k swap on /var/swap.  Priority:-2 extents:32 across:8544252k SSFS
May  7 01:17:24 Raspberry: [   26.382877] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
May  7 01:17:29 Raspberry: [   31.298005] CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-5
May  7 01:17:29 Raspberry: [   31.376097] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
May  7 01:17:31 Raspberry: [   33.509062] CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-5

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Merci bien pour ta réponse et ton lien.  J'ai déjà effectué la procédure, effectivement cela était très simple.

Reste plus qu'a attendre ce que mon Raspberry en pense cette nuit :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


  • Contenu similaire

    • Par FredP
      Bonjour,
      La bonne nouvelle matinale. A presque un mois de la fin du support des NAS legacy, Qnap apporte le supporte du SMB3 sur les NAS Legacy avec l'apport d'un Samba 4.0.25 fonctionnel.
      Je ne l'ai pas trouvé dans l'interface graphique de la console d'administration et il n'est peut-être pas disponible pour tous les anciens NAS pouvant disposer du firmware 4.26 du 20170905 disponible sur le site de QNAP...
      Pour l'activer, se rendre sur le NAS avec une connexion ssh et taper: smb3enable.
      Un texte s'affiche prouvant des redémarrages de services SMBD et NMBD, de serveurs Samba voire Wins: 
      "Shutting down SMB services: smbd nmbd.
      Shutting down winbindd services: winbindd.
      max protocol SMB 3 ... enabled.
      locks path was set to /share/"path_to_current_system_files"/.locks où "path_to_current_system_files" est le dossier où sont actuellement stockés les fichiers systèmes.
      Shutting down winbindd services: winbindd.
      Starting winbindd services:Starting SMB services:.
      smbd (samba daemon) Version 4.0.25
      smbd (samba daemon) is running.
      max protocol SMB 3 enabled.
      "
      J'avais actuellement activé SMB 2.1. Un retour en arrière? Pas de problème, vérifiez et choisissez:
      "smb2enable status
      Usage: /etc/init.d/smb2_protocol.sh {enable|disable|status} [1|2|20|21|3]
      Options:
              disable       - SMB 1
              enable 1      - SMB 1
              enable [2|20] - SMB 2.0
              enable 21     - SMB 2.1
              enable 3      - SMB 3
      smbd (samba daemon) Version 4.0.25
      smbd (samba daemon) is running.
      max protocol SMB 3 enabled."
      Bon début de journée.
      Cordialement.
      FredP
      Amusant ce support si tardif,  j'espère bien en découvrir encore quelques uns...
    • Par Traise
      Bonjour
      J'ai le problème suivant sur un NAS TS-453 firmware 4.2.1 :
      Suite à un attaque de cryptolocker  (cryptxxx v3 à priori) les utilisateurs du domaine windows n'ont plus accès aux fichiers partagés du NAS.
      J'ai tenté de repartir de 0 (redémarrage du service samba, remontée du nas sur le domaine, réapplication des différents droit sur les dossiers...), rien n'y change. Le nas me remonte bien la liste des utilisateurs et groupes du domaine mais ce n'est apparemment pas effectif.
      Si j'active le partage avancé j'ai le message d'erreur :
      [Advanced Folder Permissions] ACL user/group not found: "Domaine\Utilisateur" Pour dépanner temporairement j'ai ouvert les droits d'accès invité.
      Quelqu’un a t il une solution ?
    • Par cfreeman1978
      Bonjour,
      je possède un tvs-471 sur lequel j'ai connecté 3 cartes reseau.
      j'ai fait un trunk sur les 2 premières et sur la 3ème j'ai fait un pont pour ma vm en désactivant tous les services associés à cette carte. Je voulais qu'aucun service ne puisse passer par cette interface.
      le problème c'est que dans cette configuration, les accès samba depuis mes lecteurs multimédia ne fonctionne pas! Pour que cela fonctionne je suis obligé d'activer le service réseau Microsoft sur l'interface 3! Je ne comprend pas pourquoi cela n'attaque pas directement la première interface! De plus lorsque j'accède par l'adresse ip (en utilisant l'adresse de la première interface) cela fonctionne. De même si je débranche physiquement le cable de l'interface 3! En gros lorsque je branche le cable a l'interface 3 et que tous les services sur celle-ci sont désactivés, j'ai un timeout sur mon lecteur multimédia (je vois bien le nom de mon nas dans les partages Smb) par contre si je passe par l'adresse ip de ma première interface cela fonctionne!
      j'ai essayé en supprimant le trunk et le pontage de la vm, toujours pareil. De meme avec une 4eme connexion sur la 4eme interface! on n'a l'impression que le nas considère que l'accès samba par défaut ne sera pas sur la ou les premières interfaces si il y en a plus d'une de connecté mais peut être sur la dernière.....en sachant que l'accès samba fonctionne bien sur les première interface car en passant par l'ip cela fonctionne!
      Quelqu'un aurait-il une idée?
      merci d'avance pour votre aide.
    • Par murrey
      Bonjour messieurs

      J'ai un cas qui me pose grand problème. Je m'explique : J'ai un serveur TS 239 Pro II, sur lequel le serveur FTP est configuré.
      Voici comment est l'arborescence
      /FTP/Dir1
      /FTP/Dir2
      Comme j'ai lu des posts sur ce forum à propos des droits, j'ai compris qu'il fallait aussi regarder au niveau des share.
      Il y en a 3
      FTP qui pointe vers /FTP
      FTP.Dir1 qui pointe vers /FTP/Dir1
      FTP.Dir2 qui pointe vers /FTP/Dir2

      Pour les droits du share voici ce que j'ai configuré
      FTP.Dir 1 il y a le groupe administrators et un groupe FTP.Dir1 dans lequel j'ai mis le fameux utilisateur toto. Ce groupe a les droits RW sur le share FTP.Dir1

      Je me connecte avec toto sur le Web File Manager (de Qnap). Là je vois le répertoire FTP.Dir1. et j'ai les droits en écriture.
      Jusque là tout va bien.
      Ensuite je me connecte en FTP sur le NAS, et là je n'ai pas accès au répertoire. Il est tout vide. Rien de rien.
      Comment c'est possible ?
      Vous avez une idée ?
      Car j'ai fait d'autres tests. Mettre le groupe FTP.Dir1 sur le share FTP. Et là j'ai accès à /FTP et /FTP.Dir1. Du coup je comprends pas. Car mon but est de faire un serveur FTP où toto a accès un seul répertoire. Pas à tout.
      Merci d'avance pour votre aide.
    • Par Sylrob
      Bonjour,

      Je possède un Qnap Ts-459 pro II avec le firmware 3.5.1 Build 1002T. Mon QNAP est intégré à mon AD. J'ai un logiciel qui tourne sur un share du QNAP, ce logiciel utilise un API Windows qui requiert les droits d'administrateur pour fonctionner. (NetFileEnum())

      Ce que je désire est que les utilisateurs qui sont dans le groupe Administrateurs de mon AD soient reconnus dans le groupe Administrateur du QNAP (Samba). Comment fais t-on pour dire a Samba de reconnaitre les utilisateurs du groupe Administrateurs de mon AD comme étant des Administrateur du QNAP. Ais-je oublié une configuration en quelque part pour que ceci ce fasse automatiquement ?

      Merci,

      Sylvain
×